Closed Bug 859204 Opened 8 years ago Closed 6 years ago

PDF.js display of file is missing most text

Categories

(Firefox :: PDF Viewer, defect, P3)

29 Branch
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox27 --- affected
firefox28 --- affected
firefox29 --- affected

People

(Reporter: info, Assigned: Snuffleupagus)

References

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/issues/4147)

Attachments

(2 files)

When I view a statement (bill) from Suddenlink.net, it opens in a PDF.js tab. I see the images and ruled lines in the bill, but most of the text is missing. However I do see the text for my billing address and the account number.  The Linux PDF viewer okular has no trouble rendering (and selecting, and copying & pasting) the missing text; the Linux utility pdftotext shows all the text that pdf.js does not.

In the Firebug console, I see the output:
PDF 76ee15335036c64c3885045265e40 [1.3 [ClibPDF Library 2.02-r1-2] 301q AIX 4.3 / InfoPrint Solutions Company Afp2Pdf Version: 301q] (PDF.js: 0.7.236)
Warning: Error during font loading: properties.baseEncoding is undefined
Warning: Error during font loading: properties.baseEncoding is undefined
Warning: Error during font loading: properties.baseEncoding is undefined
Warning: Error during font loading: properties.baseEncoding is undefined

The Linux utility pdfinfo reports:
Title:          No Title
Subject:        No Subject
Keywords:       None
Author:         No Author
Creator:        InfoPrint Solutions Company Afp2Pdf Version: 301q
Producer:       [ClibPDF Library 2.02-r1-2] 301q AIX 4.3
CreationDate:   Mon Apr  8 03:57:29 2013
ModDate:        Mon Apr  8 03:57:29 2013
Tagged:         no
Form:           none
Pages:          2
Encrypted:      no
Page size:      612 x 792 pts (letter)
Page rot:       0
File size:      372314 bytes
Optimized:      yes
PDF version:    1.3

The Linux utility pdffonts reports:
name                                 type              encoding         emb sub uni object ID
------------------------------------ ----------------- ---------------- --- --- --- ---------
NewsGothicStd                        Type 1            Builtin          yes no  no      21  0
NewsGothicStd-Bold                   Type 1            Builtin          yes no  no      24  0
Helvetica                            Type 1            WinAnsi          no  no  no      27  0
Times-Roman                          Type 1            WinAnsi          no  no  no      28  0

In Firebug's HTML view I see a div class="textLayer" that contains <divs> containing the few bits of text that I see. But it is also full of dozens of empty divs such as
  <div data-canvas-width="0" data-font-name="undefined" style="font-size: 9.11601px; font-family: undefined; left: 75.142px; top: 691.775px;"></div>

I don't want to attach my bill, but I will gladly run any command or analysis on this PDF file that will help.
Attach the PDF sammple to the bug, please.
Flags: needinfo?(info)
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering]
(In reply to Loic from comment #1)
> Attach the PDF sammple to the bug, please.

Sorry, I won't, it's a bill with personal info. Repeating what I wrote "I don't want to attach my bill, but I will gladly run any command or analysis on this PDF file that will help."  I understand if you close this bug for lack of info.

I opened a new bill with latest nightly, Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20130428 Firefox/23.0, and the problem remains with the same warning messages. This time pdf.js displayed a black warning bar "This PDF document might not be displayed correctly."
Flags: needinfo?(info)
Or you could provide the PDF document to a dev by email.
Can you please try to create a similar PDF with bogus info? Or perhaps just modify the existing one.
Flags: needinfo?(info)
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → INCOMPLETE
I used pdftk to extract the second page, it's attached.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
I cleared the needinfo when I attached, I cleared it when I reopened the bug, try a third time.
Flags: needinfo?(info)
Version: 23 Branch → 29 Branch
Thanks for the test pdf, skierpage!

Reproduced the bug with the attachment on Firefox 27, 28 and 29, both on Ubuntu and Windows 7.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
Attachment #8361543 - Attachment mime type: application/force-download → application/pdf
Assignee: nobody → jonas.jenwald
Whiteboard: [pdfjs-c-rendering] → [pdfjs-c-rendering][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/issues/4147
Duplicate of this bug: 878112
It looks like this bug is fixed.
Working range: 
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9d650c07b547&tochange=9e06d42c2a6a

It's fixed by:
Bug 960051 - Update pdf.js to version 0.8.934.
Depends on: 960051
Status: NEW → RESOLVED
Closed: 7 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.