Prevent websites from tampering with data copied to the clipboard

RESOLVED DUPLICATE of bug 859127

Status

()

RESOLVED DUPLICATE of bug 859127
6 years ago
6 years ago

People

(Reporter: adrian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 734490 [details]
copypaste.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557

Steps to reproduce:

Copied the text on http://thejh.net/misc/website-terminal-copy-paste


Actual results:

I got this in my clipboard:

git clone /dev/null; clear; echo -n "Hello ";whoami|tr -d '\n';echo -e '!\nThat was a bad idea. Don'"'"'t copy code from websites you don'"'"'t trust!
Here'"'"'s the first line of your /etc/passwd: ';head -n1 /etc/passwd
git clone git://git.kernel.org/pub/scm/utils/kup/kup.git


Expected results:

I expected the actually displayed text in my clipboard:

git clone git://git.kernel.org/pub/scm/utils/kup/kup.git
The problem is that the other text is displayed too; you just didn't see it....
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 859127
You need to log in before you can comment on or make changes to this bug.