mach build looks for a non-existent warnings.json

RESOLVED DUPLICATE of bug 859078

Status

()

Core
mach
RESOLVED DUPLICATE of bug 859078
5 years ago
5 years ago

People

(Reporter: past, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Running 'mach build' in fx-team tip I get:

[...]
45:25.21 327 compiler warnings present.
Error running mach:

    ['build']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

IOError: [Errno 2] No such file or directory: u'/Users/past/src/fx-team/obj-ff-dbg/.mozbuild/warnings.json'

  File "/Users/past/src/fx-team/python/mozbuild/mozbuild/mach_commands.py", line 115, in build
    warnings_database.save_to_file(warnings_path)
  File "/Users/past/src/fx-team/python/mozbuild/mozbuild/compilation/warnings.py", line 268, in save_to_file
    with open(filename, 'wb') as fh:



The error message is correct, there is no .mozbuild directory in my objdir at all. Could it be a regression from bug 857984?

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 859078
You need to log in before you can comment on or make changes to this bug.