[Gallery] landscape mode is not retaining after indication of SMS received

RESOLVED INVALID

Status

Firefox OS
Gaia::Gallery
P2
normal
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: ntiaj12345, Assigned: Leo)

Tracking

({regression})

unspecified
1.1 QE1 (5may)
x86
Windows XP
regression

Firefox Tracking Flags

(b2g18+ affected)

Details

(Whiteboard: [TD-9808])

Attachments

(2 attachments)

3.81 MB, application/x-rar
Details
2.24 MB, application/x-rar
Details
(Reporter)

Description

5 years ago
1. Title : - Landscape mode is converted into the Full-screen view, when SMS indication is received 
2. Precondition: one image is required in Gallery
3. Tester's Action: Open Gallery -> Open any image full-scrren mode -> landscape mode -> Send SMS to the deceive from any other device -> SMS received indicator display on top -> Change the landscape mode to full-screen mode  
4. Detailed Symptom (ENG.) :  It is not retaining the landscape mode
5. Gaia Revision #:  " 8e7262e3d98ea9574d7f79c1e890ad80cfa40c27 "
6. Expected : It should retain the landscape mode
7.Reproducibility: Y
1)Frequency Rate : 100%
8.Comparison Results : 
	1)Model Comparing : 
9. Attached files: 
	1)Log : 
	2)Test Contents : 
	3)Video file :
(Assignee)

Updated

5 years ago
blocking-b2g: --- → leo?
(Assignee)

Updated

5 years ago
blocking-b2g: leo? → ---
tracking-b2g18: --- → ?
status-b2g18: --- → affected
tracking-b2g18: ? → +
Andrew tried this in v1.0.1 and did not reproduce so we're looking for a regression here.
Keywords: qawanted, regression, regressionwindow-wanted
Target Milestone: --- → Leo QE1 (5may)
(Assignee)

Updated

5 years ago
Whiteboard: [TD-9808]
(Assignee)

Updated

5 years ago
Flags: needinfo?(dflanagan)
What do you mean by fullscreen mode?
Gallery app is now native fullscreen, you don't have to do anything to go fullscreen.
Both album view and single view are fullscreen.

It used to be invoke fullscreen by clicking one image in album view but that'd been changed into native fullscreen long time ago.
There is needinfo set on me, but I don't know what the question is.

Also, I don't understand the bug description.  Maybe screenshots would help
Flags: needinfo?(dflanagan)
(Assignee)

Comment 4

5 years ago
Please check the below steps to reproduce
(1)	 GO to the gallery 
(2)	Open any one image  [Portrait view]
(3)	Rotate the device by 90 degree, so that image also rotate automatically  [LANDSCAPE View]
(4)	Send the SMS to this device, do not change the position of the device
(5)	 Wait for a moment
(6)	Image get rotate by 90 degree,  
And not coming back to LANDSCAPE View.

Please check the video uploaded in .rar file in 2 partitions.
(Assignee)

Comment 5

5 years ago
Created attachment 738908 [details]
Part 1
(Assignee)

Comment 6

5 years ago
Created attachment 738909 [details]
Part 2
I cannot reproduce it and I even cannot find the commit hash you provided at comment 0: 24e818186cc9ab4e89783c6240c2003c36124387

My attempt video
https://dl.dropboxusercontent.com/u/62628279/VID_20130418_112643.mp4

Updated

5 years ago
Keywords: regressionwindow-wanted
Priority: -- → P2
Still unable to reproduce using a current 1.1 build.

Leo, can you try the test in comment #4 again and see if you can still reproduce?
Flags: needinfo?(leo.bugzilla.gaia)
I am able to reproduce this on the Leo device with a partner-produced build. Looks like it is device specific.
Partner is investigating. Assigning to Leo for further comment.
Assignee: nobody → leo.bugzilla.gaia

Comment 11

5 years ago
Removing qawanted per comment 9
Keywords: qawanted
(Assignee)

Comment 12

5 years ago
Can't reproduce it on our side as well. Thanks.
Flags: needinfo?(leo.bugzilla.gaia)
(Assignee)

Comment 13

5 years ago
(In reply to Leo from comment #12)
> Can't reproduce it on our side as well. Thanks.

Sorry, let me take my last comment back. I am able to reproduce it on Leo device..
(Assignee)

Comment 14

5 years ago
(In reply to Leo from comment #13)
> (In reply to Leo from comment #12)
> > Can't reproduce it on our side as well. Thanks.
> 
> Sorry, let me take my last comment back. I am able to reproduce it on Leo
> device..

The problem was caused by our internal issue. Please ignore this bug report.
(In reply to Leo from comment #14)
> The problem was caused by our internal issue. Please ignore this bug report.

Thank you for investigating. Closing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.