Muted Facebook chat pops up chat window

RESOLVED WONTFIX

Status

()

Firefox
SocialAPI: Providers
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: Thomas Stache, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(platform-rel ?)

Details

(Whiteboard: [platform-rel-Facebook])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130407 Firefox/22.0
Build ID: 20130407004016

Steps to reproduce:

Configured Facebook Social API feature.
Received some messages in a group chat.
Set the group chat to "muted" on facebook.com (Message: "This conversation is muted. Chat tabs will not pop up for it and push notifications are off.")


Actual results:

No notification in Facebook toolbar, but minimized chat window popped up. Additionally Firefox' taskbar button on Windows blinked to get user attention.


Expected results:

no chat window

This could well be an issue in Facebooks provider implementation, still worth filing, I guess.
(Reporter)

Updated

5 years ago
Component: Untriaged → SocialAPI: Providers
OS: Windows 7 → All
Hardware: x86_64 → All
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130613 Firefox/23.0
Build ID: 20130613004019

In windows7, not able to reproduce. Window didn't pop up.Only notification in Facebook toolbar.

User Agent:  Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0
Build ID: 20130612084701

Actual Results:
Window popped up in WindowsXP and got notification in toolbar too.
I'm not sure if the SocialAPI supports this muting of chats. I only see it built into the functionality on facebook.com. Shane, is this something we support, is it a bug in our code, or is it something Facebook needs to work on?
Flags: needinfo?(mixedpuppy)
For the record, with the latest Nightly I see the following results.

Chat Unmuted:
 * Chat window pops up
 * Jewel icon appears in toolbar

Chat Muted:
 * Chat window pops up
 * No jewel icon in toolbar
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 22 Branch → Trunk
This would be a bug in the Facebook worker script.
Flags: needinfo?(mixedpuppy)
Whiteboard: [platform-rel-Facebook]

Updated

2 years ago
platform-rel: --- → ?
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.