[mkt] Move Netapp NFS shared storage to S3

RESOLVED WONTFIX

Status

P3
normal
RESOLVED WONTFIX
6 years ago
3 years ago

People

(Reporter: jason, Assigned: jason)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

6 years ago
As part of the Move Marketplace to Dedicated BU, we will need to move off the Netapp NFS shared storage.

Tasks:

1. Create S3 bucket and user for zamboni.
2. Sync NFS content to S3 bucket.
3. Modify CDN origin to point to S3 bucket.
4. Modify zamboni configuration to use S3, coordinate with devs.
5. Test!

I would like to begin on -dev this week, I will coordinate in #remora.
(Assignee)

Updated

6 years ago
Assignee: server-ops-amo → jthomas
(Assignee)

Updated

6 years ago
Group: infra → mozilla-corporation-confidential
(Assignee)

Comment 1

6 years ago
-dev content is synced to s3 bucket, https://github.com/mozilla/zamboni/pull/733 for settings changes.
(Assignee)

Comment 2

6 years ago
@clouserw | jason: can you describe changes for krupa?  does that make us use S3 instead of our CDN?

When zamboni save files they go to s3 instead of the local fs; both app uploads and screenshots, and any other content.

S3 will become the origin of our CDN. In production our CDN hostname will rename the same, just pointed to AWS S3 instead.

I think we will need to QA tasks that write to file storage. @clouserw for specifics on what needs to be QA.
Duplicate of this bug: 866798
(Assignee)

Comment 4

6 years ago
Instead of breaking -dev, we are going to use -altdev. https://github.com/mozilla/zamboni/pull/740

Updated

5 years ago
No longer blocks: 855801

Updated

5 years ago
Blocks: 839635

Comment 5

5 years ago
Let's revisit this once altdev is working again.

Updated

5 years ago
Depends on: 919242

Updated

5 years ago
Priority: -- → P3

Updated

4 years ago
Summary: Move Netapp NFS shared storage to S3 → [mkt] Move Netapp NFS shared storage to S3

Updated

4 years ago
Group: mozilla-employee-confidential
Component: Server Operations: AMO Operations → Operations: Marketplace
Product: mozilla.org → Mozilla Services
Version: other → unspecified
(Assignee)

Updated

4 years ago
Depends on: 999125
Rumor has it this is making too many requests to S3 and we're not sure why.  Jason - can you fill us in on all of the details you have?

Comment 7

3 years ago
As part of phx1exit under bug 1227213, all AMO volumes have been filer-unmounted and will be shredded.
(Assignee)

Comment 8

3 years ago
marketplace will stay on cloud nfs storage for now.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.