Closed Bug 859407 Opened 8 years ago Closed 8 years ago

Scrolling becomes janky quickly due to heavy DOM

Categories

(DevTools :: Netmonitor, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Optimizer, Unassigned)

Details

Attachments

(1 file)

Attached image shows one row's DOM.
On an average page, around 20's of these rows will be there (even more on most pages). Adding all the repaints and reflows due to shifting timeline on top of it makes scrolling very slow and laggy/janky. Scrolling is slow even when the timeline is not shifting, i.e. page has completely loaded.

Maybe the DOM can be reduced (as the side arrow is not shown anyways) per row.

My system is pretty fast, so its not system's fault :

CPU : Core i7 3rd gen 3610QM (quad core with hyper threading), 8 GB RAM
GPU : Intel(R) HD Graphics 4000, (GPU #2) NVIDIA GeForce GT 650M
OS : Windows 7, HWA enabled.
This is a dupe of more bugs. I'm marking bug 859062 here because it's what you suggest with the side arrow.

Slowness happens because of the repeating background in .requests-menu-subitem.requests-menu-waterfall, not DOM (having a depth of 3 or 4 boxes is not that much, tbh). That background will switch to something else in bug 859041.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 859062
Then please lets close this bug only when the slowness is gone ? because it might happen that bug 859041 introduces even further slow gradients or more DOM.

> This is a dupe of more bugs. I'm marking bug 859062 here because it's what
> you suggest with the side arrow.

I am not suggesting that, although yes, it is unnecessary here and should be removed.
 
> Slowness happens because of the repeating background in
> .requests-menu-subitem.requests-menu-waterfall, not DOM (having a depth of 3
> or 4 boxes is not that much, tbh). That background will switch to something

but 30+ times repetition of 3-4 level nesting might be much.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(In reply to Girish Sharma [:Optimizer] from comment #2)
> Then please lets close this bug only when the slowness is gone ? because it
> might happen that bug 859041 introduces even further slow gradients or more
> DOM.
> 

Bug 859041 will switch to a canvas-based background...
Moving into Developer Tools: Netmonitor component. Filter on NETMONITORAMA.
Component: Developer Tools → Developer Tools: Netmonitor
OS: Windows 7 → All
Hardware: x86_64 → All
Summary: [netmonitor] Scrolling becomes janky quickly due to heavy DOM → Scrolling becomes janky quickly due to heavy DOM
(In reply to Girish Sharma [:Optimizer] from comment #2)
> 
> but 30+ times repetition of 3-4 level nesting might be much.

Request items are flat now. Is it still slow?
(In reply to Victor Porof [:vp] from comment #5)
> (In reply to Girish Sharma [:Optimizer] from comment #2)
> > 
> > but 30+ times repetition of 3-4 level nesting might be much.
> 
> Request items are flat now. Is it still slow?

Yes, much better now. And I am assuming that this will get better with canvas based background, so closing :) .
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.