Make free apps with in-app payments really FREE

VERIFIED FIXED in 2013-07-18

Status

Marketplace
Payments/Refunds
P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: kumar, Assigned: kumar)

Tracking

2013-07-18
x86
Mac OS X
Points:
---

Details

(Whiteboard: p=2)

When an app is free (with in-app payments) let's ensure these things:
* The app is truly free and can be installed by anonymous users
* No receipt is issued for the app

Due to internal implementations of tier 0 we may need to special case apps with in-app payments for this.
Blocks: 775802
Priority: -- → P2
Whiteboard: p=2
Assignee: nobody → kumar.mcmillan
Target Milestone: --- → 2013-04-18
Target Milestone: 2013-04-18 → ---
Duplicate of this bug: 865152
When fixing this, please ensure free apps w/ in-app payments do *not* show up in paid search results. See bug 865152 for STR

Comment 3

5 years ago
(In reply to Kumar McMillan [:kumar] from comment #0)
> When an app is free (with in-app payments) let's ensure these things:
> * The app is truly free and can be installed by anonymous users
> * No receipt is issued for the app
> 
> Due to internal implementations of tier 0 we may need to special case apps
> with in-app payments for this.

Note that according to David, price tier 0 apps should still get a receipt and they shouldn't allow anonymous installs. 

We need to make a final decision on what it means for an app to be a price tier 0 app.
(In reply to krupa raj 82[:krupa] from comment #3)
> Note that according to David, price tier 0 apps should still get a receipt
> and they shouldn't allow anonymous installs. 

I spoke with David about this and it was just a misunderstanding. Apps that are free with in-app payments are a special case (they are not intended for promotions). They should work just like free apps:
- no receipt
- anonymous users can install

I'll make sure David is clear on it.

It is very important that apps with in-app payments are free because this is an essential part of the business model of in-app payments.
Target Milestone: --- → 2013-05-09
Target Milestone: 2013-05-09 → ---
Target Milestone: --- → 2013-06-13
Target Milestone: 2013-06-13 → 2013-06-20
Target Milestone: 2013-06-20 → 2013-06-27
Target Milestone: 2013-06-27 → 2013-07-04

Updated

5 years ago
Target Milestone: 2013-07-04 → 2013-07-11

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 857733
This is not working for me. These are my STR:
- log out
- search for webfighter (free w/ in-app)
- install

It asks me to log in before I can install the app which is wrong. It should allow anonymous installs.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
According to the API

https://marketplace.firefox.com/api/v1/fireplace/app/webfighter/?carrier=telefonica&lang=en-US&pro=3040fe.32.1&region=es

Webfighter has a `premium_type` of `paid-inapp` (which means it's a paid app costing $0.00 - in tier 0 and it offers in-app purchases). Since it's a paid app, we need to generate the receipt (requiring you to first sign in).

From our IRC conversation what it sounds like we need is to allow from the DevHub an option to set your app to be wholly free w/ in-app (not tier 0) in addition to having promotionally free ($0.00) paid w/ in-app.
ok. This needs a devhub fix in payments setup and possibly some fireplace work to support the new free+inapp type.
(In reply to Kumar McMillan [:kumar] from comment #8)
> ok. This needs a devhub fix in payments setup and possibly some fireplace
> work to support the new free+inapp type.

You can already make an app "free" with in-app from devhub.

Comment 10

5 years ago
I believe its already there, webfighter was uploaded before Stuarts fix was in. You can go to webfighter and change it or upload a new app to verify this.
Oh, neat! James, could you go into the prod Devhub and see if you can make Webfighter free instead of $0.00?
Flags: needinfo?(jlong)

Updated

5 years ago
Target Milestone: 2013-07-11 → 2013-07-18
(In reply to Kumar McMillan [:kumar] from comment #11)
> Oh, neat! James, could you go into the prod Devhub and see if you can make
> Webfighter free instead of $0.00?

I just did that. I'm not exactly sure what difference this makes now?
Flags: needinfo?(jlong)

Comment 13

5 years ago
I can install Webfighter without signing in to marketplace prod.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Comment 14

5 years ago
verified fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.