Closed Bug 859489 Opened 9 years ago Closed 9 years ago

ftpscraper and seamonkey hate each other

Categories

(Socorro :: General, task)

x86
macOS
task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: peterbe, Assigned: selenamarie)

Details

Attachments

(1 file)

Clearly our ftpscraper is struggling with scraping seamonkey nightlies and candidates.

I don't exactly know what the problem is, or if there really is a problem but all these warnings tell me something isn't working right.
CCing Callek, who is running the SeaMonkey build machinery, in case there's some irregularity in the data the build system leaves on the FTP server.
Assignee: nobody → sdeckelmann
Target Milestone: --- → 43
The issue is that there is an empty line in *some* but not all of the *_info.txt files.

Fixing this in ftpscraper so that we don't throw tons of errors!
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/47c111fde1aa060da1955f437a017f379a28b645
bug 859489 - ignore blank lines from seamonkey files

https://github.com/mozilla/socorro/commit/a2815d6695d97cee12c3ae11e3f05cffc9a7d7ce
Merge pull request #1189 from selenamarie/bug859489-seamonkey-empty-string

bug 859489 - ignore blank lines from seamonkey files
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
uplifting to stage
Target Milestone: 43 → 42
You need to log in before you can comment on or make changes to this bug.