Closed Bug 859555 Opened 8 years ago Closed 7 years ago

[Settings] non-translatable information in the network operator list

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, P1)

ARM
Gonk (Firefox OS)

Tracking

(blocking-b2g:leo+, b2g18+ fixed)

RESOLVED FIXED
1.1 QE1 (5may)
blocking-b2g leo+
Tracking Status
b2g18 + fixed

People

(Reporter: leo.bugzilla.gaia, Assigned: mbudzynski)

References

()

Details

(Keywords: l12y, Whiteboard: [TD-10285])

Attachments

(2 files)

1. Title : [Token] Untranslated token appears when searching for mobile networks
2. Precondition : 
3. Tester's Action : Perform manual mobile NW search
4. Detailed Symptom (ENG.) : The status of the results are in English when the selected language is Spanish.
5. Expected : 
The following tokens should be changed:
   - "current" -> "conectado"
   - "available" -> "disponible"
   - "forbidden" -> "prohibida"
Attached image screenshot
blocking-b2g: --- → leo?
Triage 4/10 - setting tracking+ as most users wont be manual searching often, but translation is required.
blocking-b2g: leo? → ---
tracking-b2g18: --- → +
Assignee: nobody → kaze
Target Milestone: --- → Leo QE1 (5may)
Keywords: l12y
Summary: [Settings][Language] Do not translate lable of network operators in manual search reuslt list → [Settings] non-translatable information in the network operator list
Whiteboard: [TD-10285]
blocking-b2g: --- → leo+
Assignee: kaze → mbudzynski
Attached file patch
Etienne: since Kaze is on PTO, and 'git blame' showed me that you made some changes in the files I modified, could you please r? this tiny patch?
Attachment #741002 - Flags: review?(etienne)
Priority: -- → P1
Comment on attachment 741002 [details]
patch

r=me with the comment addressed for the code, flagging for l10n review too.
Attachment #741002 - Flags: review?(etienne)
Attachment #741002 - Flags: review?(community)
Attachment #741002 - Flags: review+
Comment on attachment 741002 [details]
patch

(:l10n is an alias, not the most reliable method to get a review)

v1-train doesn't need l10n review, you should get copy review if needed from UX.

In this case, I guess it's needed, as we're using lower-case strings here, and I'm not sure that's right. Trying Josh for review. We might actually need real copy here, too.
Attachment #741002 - Flags: review?(community) → review?(jcarpenter)
Duplicate of this bug: 858129
leo should be translated in es, PT-BR.
Could you add es, PT-BR string also.
Flags: needinfo?(stas)
Translations are made outside of the gaia git repository. The french version that's update here won't matter for production and test builds, it's just there for developers.
Flags: needinfo?(stas)
(In reply to Axel Hecht [:Pike] from comment #8)
> Translations are made outside of the gaia git repository. The french version
> that's update here won't matter for production and test builds, it's just
> there for developers.

How can I request about translation? 
Let me know about translation process.
When the translation is complete about other languages, I would like to know.
Comment on attachment 741002 [details]
patch

Actually noting my negative feedback on the strings in this patch, for clarity.

hyuna.cho, localization is too complex a topic to put it into a bug comment. In short, once strings land on v1-train, they get picked up, and exposed to our l10n community. The builds we and partners produce pick up the latest localizations then. There's tons of technical detail here that's not helpful for this bug.
Attachment #741002 - Flags: feedback-
+state-connected = current
+state-current = current 

Ignoring the lower-case for a moment, sure the first "current" shouldn't be "connected"?
(In reply to Francesco Lodolo [:flod] from comment #11)
> +state-connected = current
> +state-current = current 
> 
> Ignoring the lower-case for a moment, sure the first "current" shouldn't be
> "connected"?

Agreed. Should be:

"Connected"
"Available"
"Forbidden"
I used lowercase strings because that is how it works now. Changed to uppercase and patch updated
Still wrong, now you have a "state-current" string with "Connected" inside

+state-connected = Connected
+state-current = Connected
Merged: https://github.com/mozilla-b2g/gaia/commit/8bcd3d970a76093385f65a0acfcaa023654572bc
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
:flod its on purpose, Connected & Current is the same thing.
Comment 12 seemed to agree with me. Anyway, if that's the case why do you need to distinct strings?
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 8bcd3d970a76093385f65a0acfcaa023654572bc
  <RESOLVE MERGE CONFLICTS>
  git commit
Any update on the merge conflict?
Flags: needinfo?(mbudzynski)
Pull request with merge conflict resolved waiting for landing: https://github.com/mozilla-b2g/gaia/pull/9992
Flags: needinfo?(mbudzynski)
v1-train: 53055a5
Testcase needed just to make sure the string is localized, not to test the actual string translation.
Flags: in-moztrap?
Flags: in-moztrap? → in-moztrap+
QA Contact: amiller
Duplicate of this bug: 881176
Attachment #741002 - Flags: review?(jcarpenter)
You need to log in before you can comment on or make changes to this bug.