If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Speaker is disabled when rejecting an incoming call during an established call

RESOLVED FIXED

Status

Firefox OS
Gaia::Dialer
P2
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: isabelrios, Assigned: gtorodelvalle)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed, b2g18-v1.0.1 wontfix)

Details

(Whiteboard: IOT, Spain, Ikura, Chile, khepera_43361, URL)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Bug filed during certification in Spain.
Device Ikura, Buildid "20130321070205"
gecko commit: b5183c99228bdc5be33340e359efd1b4f0859e92 
gaia commit: 577d13088ebdbd353d13910d3317e713a140415b

PROCEDURE
Be sure call waiting option is enabled
1. Establish a voice call between DuT and another device
2. During the call, enable the speaker
3. Receive a voice call on DuT
4. Reject it using the red key
5. Continue with the voice call which was established

EXPECTED
Rejecting a voice call while another one is established should not affect how the speaker is set

ACTUAL
When rejecting a voice call with another call established, the speaker is disabled

Updated

5 years ago
Whiteboard: IOT, Spain, Ikura

Updated

5 years ago
Blocks: 855378
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Whiteboard: IOT, Spain, Ikura → IOT, Spain, Ikura, Chile, khepera_43361

Comment 1

5 years ago
This issue does not reproduce on the Inari, unable to test on the Ikura

Comment 2

4 years ago
Created attachment 751468 [details]
Logcat of the STR

Comment 3

4 years ago
Isabel, this looks like a Gaia issue. Every time a new call is received the speaker is disabled.

Etienne, who is the best person to look at this issue?
Flags: needinfo?(etienne)
We have negotiated with carriers to waive this for v1.0.1 but they want this to be fixed for 1.1
blocking-b2g: --- → leo?
Assignee: nobody → gtorodelvalle
(In reply to Anshul from comment #3)
> Isabel, this looks like a Gaia issue. Every time a new call is received the
> speaker is disabled.
> 
> Etienne, who is the best person to look at this issue?

Just had a look. The speaker is not disabled at the when the call is received but only when one of the call is ended (the current call or the call waiting) [1].

git blame tells me German would be a good assignee :)

https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/js/handled_call.js#L226
Flags: needinfo?(etienne) → needinfo?(gtorodelvalle)
blocking-b2g: leo? → leo+
Created attachment 752633 [details]
Associated PR.

To avoid weird behaviors regarding the speaker and mute functionality, we reset them when handling the first incoming call instead of when a call is disconnected since may other calls being handled. For the proposed patch we have considered the case when a busy tone is played in which case, although the call is disconnected, the call screen is shown. If while the busy tone is played, a new call reaches the phone, it is properly reset to not muted and the speaker off.
Attachment #752633 - Flags: review?(etienne)
Flags: needinfo?(gtorodelvalle)
BTW, when testing the proposed patch I found that the speaker does not work as expected although navigator.mozTelephony.speakerEnabled is properly set and unset at a Gaia level. I am currently talking to  josea.olivera@gmail.com to include a bug in Gecko since it seems to be platform issue.

In fact, this may be related to bug 873659 where we are also observing kind of weird behaviors regarding the audio during calls.
Depends on: 874812
status-b2g18-v1.0.1: --- → affected
status-b2g18: --- → affected
status-b2g18-v1.0.1: affected → wontfix
Comment on attachment 752633 [details]
Associated PR.

Please don't break the test suite :(

The test |[communications-dialer] dialer/handled_call on disconnect mute off after call| should probably be removed :)
Attachment #752633 - Flags: review?(etienne) → review-
Wow! Sorry about that :-( At least, it has let us detect a typo in our tests: this.speakerOn at https://github.com/gtorodelvalle/gaia/blob/master/apps/communications/dialer/test/unit/mock_call_screen.js#L18 where it should be this.mSpeakerOn (the same in turnSpeakerOn()). This was causing the speaker tests to pass although we were not testing what we should ;-)

I'll update the PR in a sec.

Thank you very much, Etienne! ;)
Comment on attachment 752633 [details]
Associated PR.

Problem with the test failing solved. The 'mute off after call' and the 'speaker off after call' no longer apply so they have been removed.

Apart from this, a typo in the mock_call_screen.js file has been fixed.
Attachment #752633 - Flags: review- → review?(etienne)
Comment on attachment 752633 [details]
Associated PR.

r=me (464f272)

Thanks!
Attachment #752633 - Flags: review?(etienne) → review+
Merged in master: https://github.com/mozilla-b2g/gaia/commit/6a46bb955f6bb5bc6c8a499fb0e0c2a6262b822a

Thanks Etienne for your review ;-)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Uplifted 6a46bb955f6bb5bc6c8a499fb0e0c2a6262b822a to:
v1-train: bc3c4b6cc6e9cab8690551170e0830570e5c78aa
status-b2g18: affected → fixed

Updated

4 years ago
Flags: in-moztrap?

Updated

4 years ago
Flags: in-moztrap? → in-moztrap+
You need to log in before you can comment on or make changes to this bug.