need to check http validate before kicking imgs out of img cache

RESOLVED DUPLICATE of bug 108161

Status

()

Core
ImageLib
P3
normal
RESOLVED DUPLICATE of bug 108161
17 years ago
16 years ago

People

(Reporter: Cathleen, Assigned: Stuart Parmenter)

Tracking

Trunk
mozilla0.9.8
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
this will help ibench performance.

Comment 1

17 years ago
->0.9.3
Priority: -- → P3
Target Milestone: --- → mozilla0.9.3
(Reporter)

Comment 2

17 years ago
gagan we need this for 0.9.2, this bug is part of the problem for bug 82244, 
which pav asked me to seperate it out of that main bug
(Reporter)

Updated

17 years ago
Blocks: 82244

Comment 3

17 years ago
Pav sez that this is not a trivial change and since he has a lot of 0.9.2 bugs 
already we had moved this out to 0.9.3. If anyone can help us get this in 
earliar that'll be great!

Comment 4

17 years ago
How much impact does this have on i-bench?
See comment from bug 82244
   ------- Additional Comments From John Morrison 2001-05-22 22:44 -------

   So, I ran the ibench test with the 500MHz win98 PC, and I got:
                       
     05/21                      05/18                     
       Total          301.1       Total          291.98
       First iter.    56.63       First iter.     46.52
       Subsq. iter.   34.92       Subsq. iter.    35.07

   These are similar to paw's results on the other machine (modulo machine 
power).


   I grabbed the server logs from the test server, and after a little slicing 
   and dicing, it turns out that (with post 5/18 builds) we are not caching 
images 
   properly when they appear in more than one page. e.g., if '/path/to/some.gif' 
   is used in two different pages, it is fetched once for each page, and not 
from 
   the cache. (I have more detailed data that shows this happening).

   Now, the zdnet pages serve up a lot of pages that are identical in structure,
   and which reuse the same graphics page to page. So, effectively, very few of
   the zdnet pages are in a purely uncached state (some content that they need
   has been previously pulled in for earlier pages). But, in my test, each page 
   has a unique set of images, so the uncached round is a purely uncached round, 
   not some mixed state. 
(Reporter)

Comment 5

17 years ago
as what I understand from pav, this is something that if for any reason, a page
is reloaded, he is throwing away the images in the image cache, then get a fresh
copy from the server, but in fact, should be checking with http validate first
and reuse that image in the cache if it's still valid.

there is another bug for images not be cached properly between pages, for ibench
too...  I'll try to find it.
(Reporter)

Comment 6

17 years ago
> there is another bug for images not be cached properly between pages, for ibench
> too...  I'll try to find it.

bug 78019

Comment 7

17 years ago
-> 0.9.4
Target Milestone: mozilla0.9.3 → mozilla0.9.4
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5
(Assignee)

Comment 8

16 years ago
.
Target Milestone: mozilla0.9.5 → mozilla0.9.6
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.6 → mozilla0.9.8
(Assignee)

Comment 9

16 years ago
i'm marking this a dup of 108161 since it has patches n stuff in it.

*** This bug has been marked as a duplicate of 108161 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.