FF20 misbehaves with JAWS 11.0.1461 (screen reader)

RESOLVED DUPLICATE of bug 865240

Status

()

RESOLVED DUPLICATE of bug 865240
6 years ago
6 years ago

People

(Reporter: david, Assigned: surkov)

Tracking

(Blocks: 1 bug)

20 Branch
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557

Steps to reproduce:

Use Firefox 20 under win7 with JAWS 11.0.1461


Actual results:

Sometimes elements appear duplicated on the JAWS virtual buffer, such as words or paragraphs appearing twice. Screen refresh (insert-escape) helps a bit, must be pressed repeatedly. Otherwise, the focus on virtual buffer is lost and Firefox crashes often.


Expected results:

Nothing of the above.
Component: Untriaged → Disability Access

Updated

6 years ago
Blocks: 617918
Component: Disability Access → Disability Access APIs
Product: Firefox → Core

Comment 1

6 years ago
Did you submit any crash reports when Firefox crashed for you? If yes:
1. Open Firefox and go to about:crashes.
2. Find the first link and press Enter on it.
3. Wait for it to show a technical crash report. You may get a warning initially that your crash report is being fetched.
4. Press Ctrl+L to go to the location bar and copy the link.
5. paste it in a comment to this bug please.
Flags: needinfo?(david)
(Assignee)

Comment 2

6 years ago
CC'ing Brett just in case. It seems it should be hard to do something without steps to reproduce though.

Marco, I assume you've never seen this behavior?

Comment 3

6 years ago
No, I haven't, but that may be because I have multiple versions of JAWS installed, and newer versions tend to override older one's shared components such as FSDOmSRV and FSDomNodeFirefox, which means even in older versions, newer DLLs may do their jobs which may have fixes. it's close to impossible to get any older clean version of JAWS once newer versions are also installed.
(Reporter)

Comment 4

6 years ago
This is a link to one of the crash reports. If it's any use I can provide more:

https://crash-stats.mozilla.com/report/index/fa8a5316-b284-43e5-8236-1de682130409
Flags: needinfo?(david)
(Assignee)

Comment 5

6 years ago
Looks like a JAWS crash
(Reporter)

Comment 6

6 years ago
It may be a JAWS dll causing it, but JAWS itself doesn't crash. FWIW.

Comment 7

6 years ago
It is the DLL JAWS injects into Firefox that crashes. At that moment, part of JAWS is actually part of Firefox. As soon as this part crashes, which it clearly does, it takes down Firefox with it. The rest of JAWS continues to function.

This is a problem Freedom Scientific needs to solve, unfortunately, as we do not have access to the source code of FSDomNodeFirefox.dll.
(Assignee)

Comment 8

6 years ago
I think this bug is cased by bug 865240.
Depends on: 865240
(Assignee)

Comment 9

6 years ago
David, would you mind to check if this bug was fixed? (bug 865240 was landed)
(Reporter)

Comment 10

6 years ago
What FF do I need to run? Presumably it's not fixed on a released version yet.
(Assignee)

Comment 12

6 years ago
David P Á, did you have a chance to check it?
Flags: needinfo?(david)
(Reporter)

Comment 13

6 years ago
(In reply to David P Á from comment #10)
> What FF do I need to run? Presumably it's not fixed on a released version
> yet.

It appears to be fixed on latest nightly, yes. Sorry for delay. Many thanks for fixing.
Flags: needinfo?(david)
Thanks for the report David, and for confirming the fix!
Assignee: nobody → surkov.alexander
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 865240
You need to log in before you can comment on or make changes to this bug.