Mutt tests - mozelement.js appears to be failing, can't find elementID fname

RESOLVED DUPLICATE of bug 860655

Status

RESOLVED DUPLICATE of bug 860655
6 years ago
2 years ago

People

(Reporter: jfrench, Unassigned)

Tracking

Details

(Whiteboard: [mentor=whimboo][lang=js], URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 735210 [details]
mutt elementslib test log

Mutt test mozelement.js appears to be failing. It appears it can't find the id of the element.

mutt/mutt/tests/js/elementslib/mozelement.js

(error)
"message": "could not find element ID: fname"

(code)
mozelement.js, line 16
let textbox = findElement.ID(controller.tabs.activeTab, "fname");

I've included a full log of a test run with the manifest from that directory, run as mutt -m [manifest). I have a bunch of other bugs in the queue to land/resolve before this one, but I will try to fix it if you'd like, later. If it's urgent feel free to assign someone to skip/disable the test in the manifest and/or fix.
Please file those bugs in the Testing / Mozmill component in the future. Those are not our Mozmill tests.
Component: Mozmill Tests → Mozmill
Product: Mozilla QA → Testing
Whiteboard: [mentor=whimboo][lang=js]
(Reporter)

Comment 2

6 years ago
Thanks, will do.
(Reporter)

Comment 3

6 years ago
In the course of working on specific -m test.ini mutt test runs for bug 858731, mozelement.js appears to be consistently passing now. Marking Resolved/Worksforme as of Default Nightly 23.0a1 20130507030948, with latest Master.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
It's because we landed bug 864375, which we figured out by working on bug 860655.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 860655
(Assignee)

Updated

2 years ago
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.