Bookmark sync problem with two folders with empty names

RESOLVED DUPLICATE of bug 1213369

Status

()

RESOLVED DUPLICATE of bug 1213369
6 years ago
4 months ago

People

(Reporter: kpts44, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557

Steps to reproduce:

I use firefox sync to synchronize my bookmarks across computers (using a custom server) and it works great. I recently added my android phone to the synchronization and now have an issue with bookmarks synchronization. All my bookmarks are in the Bookmarks Toolbar and most of them don't have any title, only a favicon. Among the bookmarks I have several folders and two of them have no title.


Actual results:

When I set up firefox sync for my android device, the two folders with empty titles got merged into a single folder with no title (containing all my bookmarks) and a second empty (containing no bookmarks) folder with no title.


Expected results:

The bookmark folders should not be merged.

Comment 1

6 years ago
I would like to work on this bug. I'll try to reproduce it later to confirm.
Hi JC, I just came across your comment here: https://support.mozilla.org/en-US/questions/956534

Are you still looking for help working on this bug?  If this one doesn't work out, you might want to search for bugs marked [good first bug] in the Whiteboard field. This may also help: https://developer.mozilla.org/en-US/docs/Introduction . 

This may also be helpful to get you started on a build of Firefox for Android:

https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_for_Android
Flags: needinfo?(jcd_reyes89)

Comment 3

6 years ago
Hey Henry, thanks for the reply! Sorry, but due to the late reply I have already accepted an assignment to another patch. I may come back to this when when I'm finished with the others. Although, my main concern with this bug was whether or not it's server side or client.
Flags: needinfo?(jcd_reyes89)
Unlikely to be server-related: the Sync server is pretty much a dumb whiteboard for clients to use.
Blocks: 621584
Status: UNCONFIRMED → NEW
Component: General → Firefox Sync: Cross-client
Ever confirmed: true
OS: Windows 7 → Android
Product: Firefox for Android → Mozilla Services
Hardware: x86_64 → All
Version: Firefox 20 → unspecified
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1213369
(Assignee)

Updated

4 months ago
Component: Firefox Sync: Cross-client → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.