Status

RESOLVED DUPLICATE of bug 814571
5 years ago
5 years ago

People

(Reporter: mike_piehl, Unassigned)

Tracking

17 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557

Steps to reproduce:

The colored bar at the top of every application window regardless of OS is the Grab Bar and is part of the standard windows GUI.  It is to be used to maximize, unmaximize, and move application windows.  TB has been fine for over 10 years until version 17.  Now Tabs, when opened, occupy the Grab Bar so that it's use is degraded/eliminated as number of Tabs increases, TB is now incompatible with ALL other applications, and causes user confusion and error.  


Actual results:

Now when the Grab Bar is used as specified by the windows GUI, and TB Tabs are in the way...additional instances of TB may be created, if an instance is closed its Tab is lost, if it is closed instead of dragging it back to the "mother" TB.  And Tabs do have a purpose: to remind user of messages needing reply or to remind user of message info, etc.  So a Tab's loss can be significant.


Expected results:

The TB development team should follow standard guidelines for application window GUI.

Anything else is unacceptable.  Mozilla, this is deal breaker.

And fixing this with an add-on is, sorry, a joke!

Comment 1

5 years ago
I am running Thunderbird 17 here and I assume you talk about the Title bar, which is the same as always on my Linux system. Please provide a screenshot that does not contain private data?

> The TB development team should follow standard guidelines for application window GUI.

There are no general "standard guidelines". If you have specific specifications in mind, please provide links.
Flags: needinfo?(mike_piehl)
(Reporter)

Comment 2

5 years ago
Created attachment 735339 [details]
Screen Shot: TB Title Bar shows multiple TABS
Flags: needinfo?(mike_piehl)
(Reporter)

Comment 3

5 years ago
Hi Andre, Thanks.  Yes Title Bar, I guess you already know the "specs".  I'm sorry I don't know of any formal specs. As you probably know, X-windows and Motif, the Unix GUI's, existed since the late 70's and predate Apple's, then Microsoft's use of windows.   I'm not sure where I got the name Grab Bar which is more about user functionality than the name of an application.  Being able to re-size and move windows around on the screen is possibly the most important feature about the GUI, without it I think we all could forget about calling windows windows. I'm going to attach a screen shot that shows 8 open Tabs on my display which prevent the Title Bar from being easily used to maximize, un-maximize, and/or move the TB window. I didn't mention that my display is 1920X1200/dual-monitor although I don't think that makes a difference since I've tried it single down to 800X600.  The problem,interfering with the grab function, occurs only when the window is Maximized.  And by the way I'm using Win 7.

Comment 4

5 years ago
Thunderbird is using the title bar for the tabs as observed, that was a design decision made by the developers. There is a rather obscure off switch for this feature to switch back to the old style with a "real" title bar.

Go into Tools > Options (or Options > Options from the application button), then Advanced > General tab. Click Config Editor there to get a list of preferences. Copy-paste mail.tabs.drawInTitlebar into the search window and double-click on the setting that remains visible to set it to false. Now you should see the window decoration of the desktop again.

This change has been made for Windows only, thus no impact on Linux.
(Reporter)

Comment 5

5 years ago
Thanks, that works.

Maybe it is not well known that dragging a window's Title Bar up to the top of the display maximizes the window, and dragging a full-screen window down from the top of the screen un-maximizes the window?  That function is an important and essential part of the window's GUI.  It shouldn't be messed with!  ;-)

Comment 6

5 years ago
I'm running Thunderbird with mail.tabs.drawInTitlebar disabled myself since I don't like the new behavior either, but when switching back it appears that there is still a bit of window decoration above the tabs where you can still grab the window for the functions you describe. Only when going into maximized mode that space is gone, making it hard to minimize the window again other than by finding the minimize button in the upper-right corner.

Given that the developers likely will keep that feature as the default, the obvious solution would be to make it more discoverable how to get the title bar back by some menu function. There have been quite a few bugs filed on this issue, thus your bug will likely end up being marked as a duplicate of another bug to consolidate the discussion at a single place.
Whiteboard: dupeme

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
Duplicate of bug: 814571
You need to log in before you can comment on or make changes to this bug.