[B2G][Gallery] User is unable to open images in full view if their title contains a tilde symbol

VERIFIED DUPLICATE of bug 845707

Status

Firefox OS
Gaia::Gallery
VERIFIED DUPLICATE of bug 845707
5 years ago
4 years ago

People

(Reporter: nkot, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 735333 [details]
screenshot of the image in the full view

Description:
Images that are saved with the tilde symbol in the file name do not open in the full view while appear normally in the thumbnail view 

Repro Steps:
1) Updated to Unagi Build ID: 20130409070205
2) Enable "USB mass storage" (Settings > Media Storage)
3) Connect device to PC via USB
4) Transfer any image to your device 
5) Save it with the tilde symbol in the file name
6) Disconnect device
7) Open Gallery
8) Tap the thumbnail of the test image

Actual:
Full view screen opens up but image is not displayed, just a gray screen shown 

Expected:
User is able to open any image from the gallery in a full view

Environmental  Variables:
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/cfef36c0c8bc
Gaia: a80be95f553de517e5d8a159e04511cda5e38be4

Notes:
Repro frequency: 100%
See attached screenshot for more info.
Bug 845707 should allow ~ characters anywhere but as the first character in the filename.

If we need ~ as the first character in the filename, then we'll need to fix things deeper, since some of the file classes do tilde expansion (i.e. convert ~username into the home directory for username).
Created attachment 755503 [details]
Screenshot of /sdcard/Pictures/A~B.png
It looks like bug 845707 landed on v1-train about an hour later than when the image being tested was made, so I think that this can be duped to that bug.
I'm closing as a duplicate of bug 845707.

Now that we're using composite storage, and getting fully qualified names, we should never see a file like ~file.png (we'd instead see /sdcard/~file.png)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 845707
(Reporter)

Comment 5

4 years ago
the issue has been fixed in bug 845707

Unagi
Build ID: 20130715070218
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/6062fdf2deb8
Gaia: 55ed5e08a2250ea2d3571fff860c39e66fabed14
Platform Version: 18.1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.