Closed Bug 860063 Opened 7 years ago Closed 7 years ago

[sk] Search engine setup for Firefox Mobile for Slovak.

Categories

(Mozilla Localizations :: sk / Slovak, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 522007

People

(Reporter: Pike, Assigned: rozbora)

References

()

Details

(Keywords: productization)

We want to ship Firefox Mobile with a good list of search engines for Slovak. 

We're going to work towards this in three phases. First, the localization team and the l10n drivers will look at the market for the language and come up with a good set of search providers. Vlado, we'll need your input on this, the guidelines for making recommendations are on <https://wiki.mozilla.org/L10n:Mobile/Productization>. 

For en-US, we currently use this set, to which we can fall back in the case of lacking localized alternatives:

> Google (mobile version), Amazon, Twitter, Wikipedia (slightly different to desktop, 32x32 icon)

Once we decide to use a particular search engine (and we test it on a mobile device), l10n drivers will contact the owner and ask for permission, and for specifics like proper search flags. Vlado, we'll likely need your help to at least get the contact information.

For search engines that we already ship with on desktop and that you would like to include in mobile as well, the permission is not needed.  Consider using a mobile version of the engine if one is available.  Also, please make yourself familiar with instructions regarding the <Description/> element at <https://wiki.mozilla.org/L10n:Integrated_Search_Instructions>.

Once we have a specification on what the search engines for Slovak should look like, Milos and the localization team will work on an implementation on that. Milos will create and attach patches for the desired changes and get them reviewed. After a successful review, Milos will land them. Vlado, if you're interested, you could create the patches, too. You'd ask Milos for review on those before landing. 

Please don't commit any modifications in browser/searchplugins to the hg repository without a patch reviewed by Milos, Stas, Axel or someone else appointed by the l10n drivers. The data here is sensitive to users and our search partners, thus the extra care here.

The Slovak team and Milos will be driving this bug to completion.
Yeah, this appears to be a duplicate. Let's pick up where 522007 left off.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 522007
You need to log in before you can comment on or make changes to this bug.