autostart=true does not work in <EMBED>

RESOLVED WONTFIX

Status

()

Core
Plug-ins
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: Yohann Jardin, Unassigned)

Tracking

22 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130409 Firefox/22.0
Build ID: 20130409004013

Steps to reproduce:

Update aurora to v22.0a2 (first releasy day) then start an event which has a countdown on the website of a game. Having a greasemonkey script that start: <embed src (...) hidden=false autostart=true loop=false>


Actual results:

The song is add on the page and don't start. (Actually, flashgot plugin detect the song)


Expected results:

The script should have add the song and play it automatically, as in previous version of firefox. (I've just tried on the beta version: it works)
The embed tag has no "autostart" attribute -- this would be passed to the plugin, and its intended effect handled there.

Do you have a URL / testcase or steps to reproduce this problem?
Flags: needinfo?(yohannjardin)
(Reporter)

Comment 2

5 years ago
1) Download greasemonkey: https://addons.mozilla.org/fr/firefox/addon/greasemonkey/

2) Restart firefox to complete download

3) Install the script: https://userscripts.org/scripts/show/139372

4) Go to http://r1.bloodwars.net/r.php?

5) Fulfil the gap to register (can choose random nick, email, character name)

6) Click on Settings on the left menu ( http://r1.bloodwars.net/?a=settings )

7) You may see some text in polish. Tick the box of the line: "odgrywaj dźwięk po zakończonej wyprawie/ataku" which is followed by a box containing the url of a song

8) Click on Begin a Quest on the left menu ( http://r1.bloodwars.net/?a=quest )

9) Click on the button "Depart" in the middle of the page

A countdown of 5 minutes has just started.
At the end of this countdown, the song does not autoplay with v22.0a2
Flags: needinfo?(yohannjardin)
Which plugin is used in your testcase ?
Does it work if you switch media.windows-media-foundation.enabled to false in about:config ?
(Reporter)

Comment 4

5 years ago
Firefox is using quicktime Plug-in 7.7.3 (in Aurora) to open .mp3 files.
However, if I go on a page which url is a mp3 file of my ftp, I can listen to it without any problem.

Does it work if you switch media.windows-media-foundation.enabled to false in about:config ?
-> No


Sry, should have tried nightly version before posting here. The result on nightly: it does not work either.
Component: General → Plug-ins

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.