[Dialer] When having no service and attempting to call, "Invalid phone number" message

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: jsantell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

When attempting to make a call when the phone has no service, a message appears:

Invalid phone number
The phone number you are calling is not valid.

In addition to this, my contact's number is coloured red on their contact page and stays that way. Making a call to the contact once service is returned works as expected.

Expected:
A message that indicates a call can't be completed due to no service

Actual:
A message that says the number is invalid, and marks the number red

Can be reproduced by running into an elevator and making a call

Unagi, B2G 1.1.0.0-prerelease, built from SHA caaa81f7dfca6
Hi Casey,

When phone has no network service and could only make an emergency call, we call it [emergency only]. In the original design, gecko indicates an "invalid number error" if the user attempt to make a call in [emergency only] (because it is not an emergency number).

We would like to change it to something like "no network service error", indicating the service is not available right now. Is it a suitable solution or you have some better ideas? Moreover, what kind of error message should we display to user in this case?

Below is a table showing how we handle this kind of call fail in different cases. You may refer to it and give us some feedback if you found something is inadequate.
http://goo.gl/UwSSk
Flags: needinfo?(kyee)

Comment 2

6 years ago
Hi Szu-Yu,
How about "Emergency calls only"?

I've also updated the spreadsheet to include additional error messages.
Flags: needinfo?(kyee)
Hi Casey,

Thanks for your response. I still have some question. Would you please check the column of "my opinion" in the sheet.
http://goo.gl/UwSSk
(In reply to Szu-Yu Chen [:aknow] from comment #3)
> Hi Casey,
> 
> Thanks for your response. I still have some question. Would you please check
> the column of "my opinion" in the sheet.
> http://goo.gl/UwSSk

Hi Casey,

Just notify you again. It seems that you may miss my previous response.

From gecko's view, I would only modify the green part in the sheet. It's necessary to add a new error code so gaia can distinguish it from BadNumberError and show the different error message.

Once I finished the modification. You could go on with gaia member and make the UX part more better. Do you have any concern for the proposal?
Flags: needinfo?(kyee)

Comment 5

6 years ago
Hi there.
I'm having difficulty following your spreadsheet.  The layout confusing and hard to figure out what rows I should be adjusting.   Anyways, I've added my changes to the sheet.  Hopefully that lines up better with the actual scenarios.

Please let me know!  :) 

Thanks
Flags: needinfo?(kyee)
This bug is out of date and we suspect that it's no longer valid. If you think this is in error, please reopen it.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 862513
You need to log in before you can comment on or make changes to this bug.