Closed Bug 860084 Opened 8 years ago Closed 8 years ago

Clone history from the parent tab when opening a link in a new tab

Categories

(Firefox for Metro Graveyard :: Browser, defect)

All
Windows 8.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 24

People

(Reporter: fryn, Assigned: fryn)

References

Details

Attachments

(1 file)

To make the overlay (and app bar) back button work most effectively, we probably need to stop including about:start as a tab history item (making about:start work like about:newtab does now on Firefox desktop) and change cmd_back to display the start page when there are no more previous tab history items left.

This is closely tied to "zooming out" the tab into a thumbnail inside the Start Page when switching to the Start Page.
Blocks: 836007
No longer blocks: 836007
Duplicate of this bug: 836004
No longer blocks: 836791
Depends on: 835628
Summary: Work - Don't include about:start as a tab history item → Work - Either don't include or always include about:start as a tab history item
Depends on: 724239
Blocks: 867515
Our code is so much easier to understand than tabbrowser.xml :)
Attachment #750178 - Flags: review?(mbrubeck)
Comment on attachment 750178 [details] [diff] [review]
patch (copy history from opener tab when creating tab)

Review of attachment 750178 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/metro/base/content/browser.js
@@ +1578,5 @@
>    },
>  
> +  _copyHistoryFrom: function _copyHistoryFrom(tab) {
> +    let otherHistory = tab._chromeTab.linkedBrowser._webNavigation.sessionHistory;
> +    let history = this._chromeTab.linkedBrowser._webNavigation.sessionHistory;

Oh, ._chromeTab.linkedBrowser can just be ._browser
Comment on attachment 750178 [details] [diff] [review]
patch (copy history from opener tab when creating tab)

I'm guessing this will be a little confusing because of how it differs from other browsers (including Firefox on all other platforms), but let's try it out and see how it feels.
Attachment #750178 - Flags: review?(mbrubeck) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/70bd47701e63
Summary: Work - Either don't include or always include about:start as a tab history item → Work - Always include about:start as a tab history item
Target Milestone: --- → Firefox 24
https://hg.mozilla.org/mozilla-central/rev/70bd47701e63
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Summary: Work - Always include about:start as a tab history item → Clone history from the parent tab when opening a link in a new tab
Depends on: 961102
No longer depends on: 961102
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.