If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[email] cc/bcc fields in compose view do not collapse / expand

RESOLVED DUPLICATE of bug 1023658

Status

Firefox OS
Gaia::E-Mail
RESOLVED DUPLICATE of bug 1023658
5 years ago
3 years ago

People

(Reporter: robmac, Unassigned)

Tracking

(Blocks: 2 bugs)

unspecified
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Whiteboard: ux-most-wanted)

User Story

As a user I want to CC/BCC to be collapsed into a single line so I have more space in the message body space to type my email.

The acceptance criteria will be defined by the UX design.

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
In the compose email view, the cc, bcc and attachments fields take up so much vertical space that the user has to scroll to start typing in the message body field. This adds an unnecessary and very annoying step for every new email.

In the spec, the cc/bcc and attachments fields are merged into a single, expandable field to preserve the vertical space and allow the user to tap directly on the message body field without scrolling. 

The interaction pattern is available on page 5 of the email attachment spec, located here:

https://www.dropbox.com/s/5giljes7ao9gyrg/email-attachments.pdf

STR:
1) Launch email app
2) Tap new email icon
3) In compose view, enter a contact
4) To enter text you must first scroll, then tap.

Desired behaviour:
cc/bcc and attachments are combined into a single field that, when tapped, expands to show all three fields (see page 5 of the spec).

Updated

5 years ago
Blocks: 838006

Updated

4 years ago
Whiteboard: s=ux-most-wanted → ux-tracking

Updated

4 years ago
Whiteboard: ux-tracking → ux-tracking, ux-priority1.2

Comment 1

4 years ago
Flagging Peter on needinfo? to ensure this gets slotted for a 1.2 sprint. I realized this earlier work addresses Productivity18 in the product backlog spreadsheet (where I've also added the bug number).
Flags: needinfo?(pdolanjski)
Thanks for adding the bug number Stephany.  It's prioritized in the right spot on the backlog, so we'll see if it ends up in 1.2.
Flags: needinfo?(pdolanjski)
Blocks: 852355

Updated

4 years ago
Whiteboard: ux-tracking, ux-priority1.2 → ux-most-wanted

Updated

4 years ago
Blocks: 994991

Updated

4 years ago
Flags: needinfo?(wmathanaraj)
User Story: (updated)
blocking-b2g: --- → backlog
User Story: (updated)
Flags: needinfo?(wmathanaraj)

Comment 3

4 years ago
Created attachment 8414230 [details]
[Email]Expand_Collapse cc_bcc list.pdf

Spec uploaded.
Since we have another users story talks about expand/collapse attachments, how about change this bug title to " [email] cc/bcc fields in compose view do not collapse / expand" ?
(In reply to Juwei Huang from comment #3)
> Since we have another users story talks about expand/collapse attachments,
> how about change this bug title to " [email] cc/bcc fields in compose view
> do not collapse / expand" ?

Sure!  Changed.  At least for email, please feel free to change the subject if you think it's wrong/misleading, etc.  In the case where I or others have added some low-level implementation details to the subject, it's preferable if you can leave them in there, but feel free to re-phrase or add-in the UI/UX-facing implications/etc and push the implementation details to the end.

If you lack the ability to change the subject (via the "edit" link that will be around it), please make sure that you've explicitly listed your "Bugzilla Email" at https://phonebook.mozilla.org/edit.php since I think that automatically grants you the required bugzilla privileges.  I don't see one there right now, but since it's the same as your mozilla.com email I don't know if it's automagic or what.
Summary: [email] cc/bcc, attachments fields in compose view do not collapse / expand → [email] cc/bcc fields in compose view do not collapse / expand

Comment 5

3 years ago
Created attachment 8451511 [details]
[Email] Compose view.pdf

Spec updated
Since the scope reduction per comment 3 has made this just about the cc/bcc collapse/uncollapse and Sri has filed a bug on just that and not much has happened on this bug, duping to the newer bug with the reduced scope.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1023658
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.