Last Comment Bug 860105 - Memory report diff tool should handle gzipped files
: Memory report diff tool should handle gzipped files
Status: RESOLVED WONTFIX
[MemShrink]
:
Product: Toolkit
Classification: Components
Component: about:memory (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nicholas Nethercote [:njn]
: about.memory
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-09 17:04 PDT by Nicholas Nethercote [:njn]
Modified: 2013-04-16 16:03 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Nicholas Nethercote [:njn] 2013-04-09 17:04:03 PDT
Gzipped JSON is now the standard format for transferring memory report data.  But diff-memory-reports.json can't handle the "gzipped" part, so you have to manually gunzip the files first.  This is pretty lame.

I also wonder if I should rewrite the diff tool in Python.  I wrote it in JS because I figured that would allow it to be incorporated into Firefox easily in the future.  But maybe that'll never happen, and until then you need a JS shell build to use it, which is something of a pain.
Comment 1 Nicholas Nethercote [:njn] 2013-04-16 16:03:26 PDT
I'm going to integrate the standalone diff tool into about:memory in bug 857382.

Note You need to log in before you can comment on or make changes to this bug.