Repair gfx blocklist for newest Intel drivers on Firefox 20

RESOLVED INVALID

Status

()

Core
Graphics
RESOLVED INVALID
5 years ago
a year ago

People

(Reporter: Shaun, Unassigned)

Tracking

20 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [platform-rel-Intel])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
Build ID: 20130408165307

Steps to reproduce:

Troubleshooting shows that graphics acceleration is off and blocked.


Actual results:

The newest Intel drivers for Ivy Bridge graphics chips renamed their driver files and thus triggered the blocklist.


Expected results:

The blocklist has been updated but should be patched to Firefox 20, 21 and 22 because this is not a new issue, just a bug with updates. Patching only Nightly 23 will cause Windows 8 users to deal with a non-accelerated Firefox for the next 18 weeks.

In fact, the workflow for blocklist management should be faster in keeping up with the latest, since the purpose of the blocklist is to ensure that it works with all latest drivers that support the relevant acceleration feature sets. If it blocks both old and new drivers, it becomes a laughing-stock.
(Reporter)

Updated

5 years ago
Component: General → Graphics
I was just about duping to Bug 844031 when I saw that you voted for that one.

That one is approved for 22 and likely to get approved for 21.
The Probability that a 20.0.2 gets spinned just for this is nearly zero.

So what is this Report about?
(Reporter)

Comment 2

5 years ago
Ah. So the term here is "uplift".

This report is about uplifting the blocklist update all the way to Firefox 20. If the final decision is Firefox 21, still better than nothing. I understand that only critical security updates make it into Firefox 20?
Whiteboard: [platform-rel-Intel]
(Reporter)

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.