New tabs with PDF content opened from modal dialog in applet are inaccessible

RESOLVED WONTFIX

Status

()

Core
Plug-ins
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: Robert Klemme, Unassigned)

Tracking

({regression})

20 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.43 Safari/537.31

Steps to reproduce:

PDF content is set to "Preview in Firefox".  I have an applet running in one tab.  The applet opens a modal dialog.  In the dialog there is a JLabel with a hyperlink pointing to a PDF document on the same server.  I clicked the link.


Actual results:

Nothing visibly: apparently the browser remembers the click and opens the new tab with the document after the modal dialog has been closed.

Note: if I set content setting for PDF to be opened in an external application the document is downloaded and the external application (e.g. Adobe Reader) starts showing the document.


Expected results:

A new tab opens showing the document.  I am able to navigate the tab and look at the document.
(Reporter)

Comment 1

5 years ago
Note: description of bug 592395 sounds similar but I am unsure whether this is actually a duplicate.
(Reporter)

Comment 2

5 years ago
Oh, I just notice that the user agent in comment 0 is that of the reporting browser.  The browser which shows the issue has this UA:

User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

Comment 3

5 years ago
Provide testcase if possible, please.
Flags: needinfo?(shortcutter)
(Reporter)

Comment 4

5 years ago
(In reply to Loic from comment #3)
> Provide testcase if possible, please.

Thank's for calling!  I'll try to create a minimal test case and attached it here.
Flags: needinfo?(shortcutter)
(Reporter)

Comment 5

5 years ago
Created attachment 736245 [details]
Eclipse project with source and a compiled Applet.

(In reply to Loic from comment 3)
The archive contains a complete Eclipse project and in directory "data" a HTML file which loads the applet.  Click the button to open the modal dialog.  Then click on the hyperlink (say, three times).  You should not see the effect described in comment 0.

Comment 6

5 years ago
Another occurence after bug 785348 landed.
Robert O'Callahan — Bug 785348. Part 1: Track when we've called into plugin code. While we're in plugin code, never run the refresh driver. r=mats

Probably WONTFIX.
Blocks: 785348
Component: Untriaged → Plug-ins
Keywords: regression
Product: Firefox → Core

Comment 7

5 years ago
Indeed. Plugins really should not be showing modal dialogs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 8

5 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #7)
> Indeed. Plugins really should not be showing modal dialogs.

Why that?  Modal dialogs are a feature of all sorts of UI technologies.  On what basis do you decide that plugins should not show modal dialogs - especially since this has worked in the past?  From a user's perspective this is a significant degradation.

If you close this then please at least provide proper reasoning.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 9

5 years ago
I decide that because plugins have no good way to do modal interfaces without interfering with other web content, and there is really no chance that we will have enough cooperation from plugin vendors to fix that fundamental design issue.

The changes here simply protect internal Firefox state from poor behavior by plugins, and we aren't going to change that because of this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 10

5 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #9)
Thank you for the explanation, Benjamin!
You need to log in before you can comment on or make changes to this bug.