[b2g] "Payment failed. Try again later" message is displayed every time when trying to buy an app

RESOLVED WORKSFORME

Status

Marketplace
Payments/Refunds
--
major
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Victor Carciu, Unassigned)

Tracking

x86_64
Windows 7
Points:
---

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 735732 [details]
Logcat

Prerequisites:
Unagi device with latest build installed from https://releases.mozilla.com/b2g/(1.1.0.0)
MP-dev app installed from http://people.mozilla.org/~kmcmillan/mktdev.html
Movistar SIM , roaming activated

Steps to reproduce:
1.Login to MP-dev app with valid credentials
2.Find a paid app(ie. "Test App(baboon71)") and press the price button

Expected results:
The "Enter PIN" screen is displayed and users are able to buy the apps following purchase flow

Actual results:
"Payment failed. Try again later" message is displayed for every paid app 

Please see attached logcat
in logcat: "navigator.mozPay error: PAY_REQUEST_ERROR_NO_VALID_REQUEST_FOUND"

This error means your device's payment preferences are configured to use the Marketplace Dev server. Could you make sure you have pushed these prefs? https://github.com/mozilla/webpay/blob/master/ezboot/custom-prefs.js

Here's an automated way to configure an Unagi device with test preferences: https://webpay.readthedocs.org/en/latest/use_hosted_webpay.html#set-up-a-device-with-ezboot

Updated

5 years ago
Blocks: 775802
Target Milestone: 2013-04-11 → ---
(Reporter)

Comment 2

5 years ago
(In reply to Kumar McMillan [:kumar] from comment #1)
> in logcat: "navigator.mozPay error: PAY_REQUEST_ERROR_NO_VALID_REQUEST_FOUND"
> 
> This error means your device's payment preferences are configured to use the
> Marketplace Dev server. Could you make sure you have pushed these prefs?
> https://github.com/mozilla/webpay/blob/master/ezboot/custom-prefs.js
> 
> Here's an automated way to configure an Unagi device with test preferences:
> https://webpay.readthedocs.org/en/latest/use_hosted_webpay.html#set-up-a-
> device-with-ezboot

We pushed the correct preferences and now the PIN is required and user is asked for the phone number when a correct PIN is entered.
Unfortunately nothing happened after entering the correct mobile phone number(we tried many variants without success). Please note that we are using a Telefonica SIM and Spain is detected automatically so the location should not be a problem.
We will attach again the logcat and also the actual user.js file .
Please help us to find a solution for this problem.
(Reporter)

Comment 3

5 years ago
Created attachment 737487 [details]
Logcat after entering the mobile number
(Reporter)

Comment 4

5 years ago
Created attachment 737488 [details]
Modified user.js file
Hi Victor. You are correct, the confirm-your-number screen should not show up when on a Telefonica SIM.

Can you attach an HTTP log? This is separate from logcat. HTTP logging will help us see what the responses are from the MobileID service. I do HTTP logging with `ezboot http` https://github.com/kumar303/ezboot More info here: https://developer.mozilla.org/en-US/docs/Mozilla/Debugging/HTTP_logging#Firefox_OS_phones

Also, make sure that 'console logging' is enabled in your Developer settings on device. The logcat you pasted does not have any log messages.
You also must have wifi disabled and cell network data enabled
(Reporter)

Comment 7

5 years ago
Wifi is disabled and we are working with data and roaming enabled.

Comment 8

5 years ago
Created attachment 738002 [details]
logcat payment failed

I have tried to make a purchase, with the user.js file modified. It worked yesterday (worked to the mobile number step), but now it says Payment failed, and unfortunately I cannot make a HTTP logging because of this. I have attached the logcat with this issue. I have tried all the possibilities but nothing worked.
You still don't have payments prefs set up. You can find info on how to set it up from this guide: https://webpay.readthedocs.org/en/latest/use_hosted_webpay.html#build-a-custom-b2g-profile
To clarify: the logcat suggests that you don't have the right prefs. Can you pastebin your prefs if you are sure that they are in user.js and on the device?
Flags: needinfo?(cboldan.mozbugs)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(cboldan.mozbugs)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.