Time set manually drifts quickly

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
6 years ago
8 months ago

People

(Reporter: past, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I do not see an option to have date/time set automatically in my Unagi, presumably due to incompatibilities with my Vodafone GR SIM card. So I have set it manually to the correct time, but I noticed today that it had drifted about 10 minutes away in a couple of days. I know that because I used the Reset Phone option on Monday and had to set the time again.

How come B2G doesn't sync with NTP servers while I am on wifi at least?

Comment 1

6 years ago
Is bug 714355 related to what you are saying?
(In reply to khu from comment #1)
> Is bug 714355 related to what you are saying?

I'm not sure. My attempts to find out whether Vodafone GR supports NITZ came up empty. I certainly had the SIM card in the phone when I observed the time drift, so it doesn't look like bug 714355 is immediately applicable here. If you can provide me with instructions to verify whether NITZ is used, I'll be happy to do so.

Comment 3

6 years ago
I don't have the answer. Not sure if Gene has such instruction?
If the carrier/SIM you're using can support NITZ, then the "Set automatically" option must be shown in the Setting App -> Date & Time. If not, then that means:

  - Vodafone doesn't support NITZ.
  - we're having a bug!
(In reply to Gene Lian [:gene] from comment #4)
> If the carrier/SIM you're using can support NITZ, then the "Set
> automatically" option must be shown in the Setting App -> Date & Time. If
> not, then that means:
> 
>   - Vodafone doesn't support NITZ.
>   - we're having a bug!

It doesn't show up, but I don't know how to tell which one of these two conditions hold. Another reason for me not dismissing the possibility of a Vodafone-related bug, is that I don't get the Data and A-GPS settings dialogs populated with values, even though I can see apn.json containing values for Vodafone GR. I always have to enter custom settings in those panels.

Comment 6

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.