Last Comment Bug 860306 - Complete Themes don't get updated via autoupdate anymore
: Complete Themes don't get updated via autoupdate anymore
Status: RESOLVED FIXED
p=1
:
Product: addons.mozilla.org Graveyard
Classification: Graveyard
Component: Public Pages (show other bugs)
: unspecified
: All All
: P1 critical
: 2013-04-18
Assigned To: Christopher Van Wiemeersch [:cvan]
:
:
Mentors:
: 861561 861616 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-10 08:30 PDT by Aris
Modified: 2016-02-04 14:51 PST (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Aris 2013-04-10 08:30:38 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
Build ID: 20130408165307

Steps to reproduce:

Tested Noia 4 v1.8.0 and FXChrome v18.1 with Firefox 20 on Windows 7 and MacOSX.

Both themes already got newer fully reviewed versions (v1.8.1 and v20.1), so they should appear on browsers autoupdate.

https://addons.mozilla.org/en-us/firefox/addon/noia-4/
https://addons.mozilla.org/en-us/firefox/addon/fxchrome/




Actual results:

No updates were found.


Expected results:

Updates should have been found and downloaded/installed automatically.
Comment 1 Kris Maglione [:kmag] 2013-04-12 14:46:09 PDT
It looks like the problem is that we now have "urn:mozilla:complete-theme:" where we should have "urn:mozilla:theme:". Fallout of revision a630af36d91dbbb64bff27bc88f1c5854a676e1f, I guess.

cvan, can you take this? That was your commit.
Comment 2 rctgamer3 2013-04-14 05:28:22 PDT
See also: bug 861616 and bug 861561.
tl;dr: Got several complaints from users about my theme not installing/updating. Please fix this ASAP.
Comment 3 Kris Maglione [:kmag] 2013-04-15 12:30:23 PDT
*** Bug 861561 has been marked as a duplicate of this bug. ***
Comment 4 Kris Maglione [:kmag] 2013-04-15 12:30:41 PDT
*** Bug 861616 has been marked as a duplicate of this bug. ***
Comment 5 Christopher Van Wiemeersch [:cvan] 2013-04-15 13:50:55 PDT
https://github.com/mozilla/zamboni/commit/61656a3
Comment 6 Cristian Boldan 2013-04-16 05:21:01 PDT
I have installed Noia 4 v1.8.0 on FF20, Aurora, Nightly https://addons.mozilla.org/en-US/firefox/addon/noia-4/versions/1.8.0 and restarted Firefox. Went to Add-ons Manager and Checked for Updates, but "No Updates Found" message was displayed, even though the latest theme version is 1.8.1.
Comment 7 Aris 2013-04-16 05:43:28 PDT
Same here, but I think Chris post implies the fix gets live on 18. April or am I wrong?

"Target Milestone: --- → 2013-04-18"
Comment 8 Wil Clouser [:clouserw] 2013-04-16 08:16:32 PDT
That's correct.  Cristian: please test on -dev
Comment 9 Kris Maglione [:kmag] 2013-04-16 11:35:28 PDT
If there's a version of the update service running on -dev, I don't know the URL. However, I'm fairly confident that this fix is correct, so it would be easiest to test after the push Thursday.
Comment 10 Cristian Boldan 2013-04-17 01:13:41 PDT
(In reply to Wil Clouser [:clouserw] from comment #8)
> That's correct.  Cristian: please test on -dev

We don't have any Complete Theme available on -dev that are compatible with FF20, therefore, only older complete themes are available. We could use a data push from production in order to test this on -dev. Please tell me if there is any schedule on this action, and don't forget to give me and Victor admin privileges on -dev once you push, cause we always lose those when this operation is made.
Thank you.
Comment 11 Kris Maglione [:kmag] 2013-04-17 02:10:31 PDT
You can just bump the compatibility for an incompatible theme on its developer version page, which has the side benefit of testing the compatibility override, which is also affected by this bug.

Note You need to log in before you can comment on or make changes to this bug.