pentastars.com - <dt> rendered on top of <dd> with margin- and padding- style info defined

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
P4
trivial
VERIFIED FIXED
17 years ago
3 years ago

People

(Reporter: Nick Stenz, Assigned: bc)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
BuildID:    2001053104

Here's the stylesheet stuff from the <head>:

dd{font-size:12pt;font-family:"Trebuchet MS",Tahoma,"New Century Schlbk";text-
indent:2pt;margin-left:2pt;padding-left:4pt;border-left:6pt solid gray}

dt{font-family:Charcoal,"Trebuchet MS",Tahoma;margin-top:2pt;padding-
top:2pt;height:2pt}


Reproducible: Always
Steps to Reproduce:
Check out the test URL in Mozilla, then IE (Opera too if you have it):
http://www.pentastars.com/inside/


Actual Results:  Mozilla renders the <dt> on top of the <dd>.


Expected Results:  IE renders <dd> below the <dt>. Opera, however, renders it 
like Mozilla.

It looks like Opera and Mozilla are assuming position: absolute for the style. 
IE must be assuming position: relative. There's none defined in the <style> tag.

However, it's only using margin- and padding-; neither of those should affect 
positioning of the actual element, since they both deal with the edge of the 
element.

Looking at it again, it's probably the height: 2pt that's breaking it. Should 
Mozilla be rendering the <dt> on top of the <dd> if it's only supposed to be 
2pt tall?

I'm not sure which one of these behaviors is correct. I'm getting an error 
trying to connect to the W3C web site at present. Can someone else say with any 
certainty?

Comment 1

17 years ago
Verified on
build: 2001-06-27-04-Trunk
platform: Win NT

The page is not rendered properly.
Changing the component to Layout.
Status: UNCONFIRMED → NEW
Component: HTML Element → Layout
Ever confirmed: true
Ummm.  The stylesheet contains:

dd{font-size:12pt;font-family:"Trebuchet MS",Tahoma,"New Century
Schlbk";text-indent:2pt;margin-left:2pt;padding-left:4pt;border-left:6pt solid gray}
dt{font-family:Charcoal,"Trebuchet
MS",Tahoma;margin-top:2pt;padding-top:2pt;height:2pt}

dt { height: 2pt; } says that the height of dt elements should be 2pt.  This
means their contents overflow them.  As far as I can tell, the layout is exactly
correct according to the CSS spec.  I didn't look all *that* closely, but I'd
certainly expect something pretty similar to the current layout.


Changing component to Evangelism to notify the site's owner, although if it's
not worth it then the bug should be marked INVALID.
Assignee: clayton → bclary
Component: Layout → Evangelism
QA Contact: bsharma → zach
(Assignee)

Comment 3

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
(Assignee)

Updated

17 years ago
Priority: -- → P4
Summary: <dt> rendered on top of <dd> with margin- and padding- style info defined → pentastars.com - <dt> rendered on top of <dd> with margin- and padding- style info defined

Comment 4

16 years ago
fixed, looks fine to me now 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 5

16 years ago
Verified, but title image is broken.
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.