No obvious link to "My Submissions" in devhub from dashboard

VERIFIED FIXED in 2014-07-29

Status

P4
normal
VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: basta, Assigned: delza)

Tracking

2014-07-29
x86_64
Windows 7
Points:
---

Details

(Whiteboard: [repoman][see comment 13])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

6 years ago
This is extremely frustrating and needs to change because I can't remember the URLs and the pages are not awesomebar-friendly.
Can you link to the URL on which you got frustrated?
Basta, there's a link to the "My Submissions" page in the gear drop-down.

http://f.cl.ly/items/471h1V333S361w2k260a/Screen%20Shot%202013-05-01%20at%2010.29.27%20AM.png

What would you like to see changed?
Flags: needinfo?(mattbasta)
Priority: -- → P4
(Reporter)

Comment 5

6 years ago
The gear implies settings. My submissions aren't settings. Why isn't the link to my existing submissions next to the link to create a new submission? Everything is bad.
Flags: needinfo?(mattbasta)

Comment 6

5 years ago
Created attachment 777613 [details]
DevHub - navigation - 01

Attached is a set of mockups that proposes a tweaked navigation system that would be consistent and ever-present across DevHub.

The problems that I was trying to solve lies in the state of our navigation today: numerous duplicated/overlapping menu items, no “you are here” indicator, and impossible lateral navigation.

In order to solve these, I chose had to fit our pages into a hierarchical model. Everybody will have an opinion as to what order works best, so this scheme isn’t final in any way. Feel free to move things around.

I could quickly resolve this bug by simply having more items on the first-level navigation, but doing this would still leave the organization in a messy state. Hence, a more long-term (but less easy to implement) solution is needed.

The idea is to have two tiers of navigations:
1. The first tier is located up top
2. The second tier is below and colored white. If the first tier has child items, then they will show up here. If the first tier has no child, this tier is not shown.


STRUCTURE
---------

0. Home (the icon): the same front page we have today

1. Learn
   a. Documentation: the first page of the docs, “Concept: A great app”
   b. API reference: a page on MDN
   c. Partners
   d. Developer Preview Phone: currently a link on the bottom of Home

2. Tools: although the tools are not made into prominent navigation items, I hope that putting them under an obvious heading will make them more accessible and help solve the problem that Basta raised
   a. App Validator
   c. In-App Payment Keys

3. Submit an App

4. My Submissions

5. Gear icon (user-related)
   a. Account Settings
   b. Return to the Marketplace
   c. Sign Out
I like that mockup, but the "My submissions" submenu has a couple issues IMHO:
- What about developers with a dozen apps, or with very long names ? The menu is going to overflow
- There is nothing to distinguish "Statistics" from app names, it might get confusing (especially if you are a stats geeks and your app are all about stats somehow :)
(In reply to Mathieu Pillard [:mat] from comment #7)
> - What about developers with a dozen apps, or with very long names ? The
> menu is going to overflow

Unless I missed it, the mocks didn't show a list of the app names as a drop-down for the "My Submissions" navigation link. If we do want that, we can limit it to 8 as we do right now: http://f.cl.ly/items/1J3216331L3F0Z1Y0s00/Screen%20Shot%202013-07-18%20at%209.48.11%20AM.png

Comment 9

5 years ago
(In reply to Mathieu Pillard [:mat] from comment #7)
> - What about developers with a dozen apps, or with very long names ? The
> menu is going to overflow
> - There is nothing to distinguish "Statistics" from app names, it might get
> confusing (especially if you are a stats geeks and your app are all about
> stats somehow :)

I’ve thought about this problem when designing, though haven’t came up with an ideal solution.

One thing I thought of was to keep stacking application names on the white navigation bar until the horizontal space run out, with “Statistics” on the rightmost side.

When the names exceeded the allotted space (not sure how to detect this), we can collapse the whole list into a vertical dropdown that will show up on hover. We have to give this list a title, but we can’t simply call this list “My submissions”, because the page is already called the same name. So we’ll call it something else; for example, “All apps”. Of course, “Statistics” will still appear to the right of this hoverable menu item.

What do you think?
What do you think?

Comment 10

5 years ago
Created attachment 778307 [details]
DevHub - my submissions (many apps) - 01

This is the mockup that visualizes what happens to the My Submissions page when the number of apps exceed the horizontal space of the white navigation bar.

Updated

5 years ago
Assignee: nobody → bram

Comment 11

5 years ago
Created attachment 780835 [details]
DevHub - navigation - 02

The navigation has been updated to incorporate feedback from Tony.

What’s changed in this design:
Instead of putting the second-level navigation items on the white bar up top, this iteration eliminates this vertical bar and instead uses the sidebar to expose *both* the first and second-level navigation items. This makes navigation consistent across the site.

Because everything needs to fit on the sidebar, it will contain a lot of items. But because it’s vertically arranged, space is naturally never an issue, and we can put as many things as we want. This is helpful when a developer has a lot of apps submitted.

At least two of our pages, “Partners” and “Developer Preview Phone”, occupy the full width of the column. Putting a sidebar navigation on them will mean that we will need to resize them down to 745px. I can work on the CSS code, and it shouldn’t take too long to tweak.

Let me know what you guys think of using the sidebar extensively across the site?
Attachment #777613 - Attachment is obsolete: true
Attachment #778307 - Attachment is obsolete: true
(Reporter)

Updated

5 years ago
Duplicate of this bug: 857601
UI: Pull "my submissions" out of the gear menu and put it into the top nav. On pages where the secondary menu is shown, remove "my submissions" from the secondary menu. In unlogged-in states, clicking on "My Submissions" should request the user log-in before taking them to the my submissions page on successful log-in.

Updated

4 years ago
Assignee: bram → nobody
Keywords: uiwanted

Updated

4 years ago
Assignee: nobody → delza
Whiteboard: [repoman]
Whiteboard: [repoman] → [repoman][see comment 13]
(Assignee)

Comment 14

4 years ago
Narrowed the scope of this issue significantly based on comment #13. Capturing the "App Validator" requirement separately: https://bugzilla.mozilla.org/show_bug.cgi?id=1041629.

Also removed extraneous "Add a New App" in secondary nav since we already have "Add an App" in primary nav.

Fixed in PR https://github.com/mozilla/zamboni/pull/2329
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2014-07-29
Summary: No obvious link to "My Submissions" or "App Validator" in devhub from dashboard → No obvious link to "My Submissions" in devhub from dashboard

Comment 15

4 years ago
Verified in marketplace-dev.allizom.org in FF34 (Win7)
The "My Submission" link is now placed next to the "Submit an app" link: http://screencast.com/t/K1MFGtTvmNuK

Shouldn't the "My submission" link also be removed from the gear icon drop down menu in marketplace homepage? The link is still present there: http://screencast.com/t/C2kFhUuUQx8f

Also, before the change when hovering over the "My Submission" link a list of submitted apps was displayed, now on hover nothing happens.
Flags: needinfo?(delza)
(Assignee)

Comment 16

4 years ago
Yes, the My Submissions should be removed from the gear menu on homepage, I missed that.


I can add the hover to see list of apps when the user is logged in if that's requested. Since we show the menu now whether they are logged in or not (prompting for login if they click and are not logged in) I didn't put it in because the list is only a click away and this keeps things consistent, but I'm happy to revisit that decision.
Status: RESOLVED → REOPENED
Flags: needinfo?(delza)
Resolution: FIXED → ---
(Assignee)

Comment 17

4 years ago
(In reply to Madalin Cotetiu from comment #15)

> Shouldn't the "My submission" link also be removed from the gear icon drop
> down menu in marketplace homepage? The link is still present there:
> http://screencast.com/t/C2kFhUuUQx8f

Sorry, should have looked at that screencast before replying. The "My submissions" link is still in the gear icon on the marketplace homepage because there is no nav menu to add it to like there is in the developer pages. Sorry for the confusion. Re-closing this.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → INVALID
Even though you didn't need to implement what was requested in comment 15, this bug has been fixed.
Resolution: INVALID → FIXED

Comment 19

4 years ago
Verified as fixed in marketplace-dev.allizom.org.
Closing.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.