When using Personas on Mac, the title bar is overlaid by the tab bar

RESOLVED FIXED in Thunderbird 23.0

Status

Thunderbird
Theme
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: standard8, Assigned: Paenglab)

Tracking

({regression})

Trunk
Thunderbird 23.0
All
Mac OS X
regression

Thunderbird Tracking Flags

(thunderbird22+ fixed, thunderbird23+ fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 735885 [details]
Screenshort of overlap

When runnning with Personas on Mac, the tab bar goes up and over the title bar. If you run with the default theme, then everything is as expected with the tab bar underneath the title bar.
(Assignee)

Comment 1

4 years ago
Created attachment 736154 [details] [diff] [review]
proposed fix

This is because we don't use the titlebar vbox under OS X. I'm still waiting for the finished Firefox draw in titlebar implementation to port it to TB. This patch is a workaround until we can port the end solution. FX also used sometime this approach. So it's not really a hack.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #736154 - Flags: ui-review?(mconley)
Attachment #736154 - Flags: review?(mconley)
Comment on attachment 736154 [details] [diff] [review]
proposed fix

Yep, totally. Thanks Richard!
Attachment #736154 - Flags: ui-review?(mconley)
Attachment #736154 - Flags: ui-review+
Attachment #736154 - Flags: review?(mconley)
Attachment #736154 - Flags: review+
Comment on attachment 736154 [details] [diff] [review]
proposed fix

This is a super-safe take for comm-aurora.
Attachment #736154 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Attachment #736154 - Flags: approval-mozilla-aurora? → approval-comm-aurora?
https://hg.mozilla.org/comm-central/rev/b30782c12707
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-thunderbird23: --- → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 23.0
(Reporter)

Updated

4 years ago
Attachment #736154 - Flags: approval-comm-aurora? → approval-comm-aurora+
(Reporter)

Comment 5

4 years ago
https://hg.mozilla.org/releases/comm-aurora/rev/08e64e72be79
status-thunderbird22: --- → fixed
(Reporter)

Updated

4 years ago
Blocks: 876710
You need to log in before you can comment on or make changes to this bug.