Complete log file is not generated when running the Perl script for specific url's.

VERIFIED FIXED in M8

Status

SeaMonkey
General
P2
blocker
VERIFIED FIXED
19 years ago
13 years ago

People

(Reporter: bsharma, Assigned: Bill Law)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Perf], URL)

(Reporter)

Description

19 years ago
Build: M8

When Performance perl script is run for the "yahoo", "aol" and "microsoft"
then complete log file is created for "aol" but not for "yahoo" and "microsoft".

This is for Windows and Linux.

Updated

19 years ago
Assignee: don → law
Component: Apprunner → Browser-General
Target Milestone: M8

Comment 1

19 years ago
law is checking into this for us.

Updated

19 years ago
Whiteboard: [Perf]
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Severity: normal → blocker

Comment 2

19 years ago
This is blocking our ability to run auto Perf test.  How we doing on
investigation?
(Assignee)

Updated

19 years ago
Priority: P3 → P2
(Assignee)

Comment 3

19 years ago
Bindu has provided me the Perl scripts and some instruction on how to recreate
the problem.  I'll look at this today.  I'm bumping up the priority a notch.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

19 years ago
The problem is due to buffering of stdout.  This prevents the "Document: Done
(xx.yy sec)" message from appearing until sufficient output is written, or, the
application terminates normally.

Since the message is the very last thing output, and the app is killed, it never
gets written out.

I fixed this by turning off buffering of stdout (one line added to
mozilla/xpfe/bootstrap/nsAppRunner.cpp).

Updated

19 years ago
QA Contact: leger → bsharma
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.