Fix the sudden jump in sessions

VERIFIED FIXED in 2013-04-11

Status

P1
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: clouserw, Assigned: andy+bugzilla)

Tracking

2013-04-11
Points:
---

Details

(Reporter)

Description

6 years ago
There was a sudden jump in rows in the django_session table around Apr 4th-5th.  We averaged around 5MM rows, but are suddenly up to 33MM today.  There are no sessions older than today (daily GC is working) and the sessions all appear to contain the same data, which decoded, is essentially "testcookie=worked".

You (andym) have done the most investigation on this.  Let's hope your current theory about django's session deleter being broken is right. :)  Thanks for investigating.  Let IRC know if you need help, I'm sure db/ops is happy to help with anything to fix their swapping servers. :)
It's not about us being happy that "our swapping servers are fixed", it's that  everyone, devs and ops, will be happy when the addons services do not fall over due to this extra load. This is an extremely important problem we are catching before it brings servers down.
(Assignee)

Comment 2

6 years ago
https://github.com/mozilla/zamboni/commit/806c84

Testing out signed cookies, so we don't need db sessions at all.
(Assignee)

Comment 3

6 years ago
See also bug 860509
Awesome! Be sure to let us know how it goes. :)
(Assignee)

Comment 5

6 years ago
It was hairy, has the db traffic dropped?
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Duplicate of this bug: 795363
You've already deployed it to production?
(Assignee)

Comment 8

6 years ago
Yep.
(Assignee)

Updated

6 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.