Closed Bug 860548 Opened 7 years ago Closed 7 years ago

[B2G][Wifi] Cannot browse using wifi on Leo and Buri

Categories

(Firefox OS Graveyard :: Wifi, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:leo+)

VERIFIED WORKSFORME
blocking-b2g leo+

People

(Reporter: mlevin, Assigned: vliu)

Details

(Keywords: smoketest, Whiteboard: leorun1,RN5/29)

Attachments

(8 files)

Description:
After successfully connecting to wifi, User cannot browse nor open Marketplace.

Attachment: Logcat

Repro Steps:
1) Manually update to Unagi Build ID: 20130410070209
2) Open Settings - Wifi and turn on wifi.
3) When the list of wifi networks appear choose one of them.
4) Enter correct password and click "ok".
5) Ensure "connected" message appears.
6) Open browser and try to view a web page.

Actual:
"Server not found" message is received many times when trying to browse.

Expected:
The ability to browse the internet with ease while connected to wifi.

Environmental  Variables:
Kernel Date: Mar 15
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/423f7851bdb5
Gaia: c614b3f3c956dc1e1adf93cf4cf41511ce75de80

Notes:
Repro frequency: (3/3))
Q Analysts Test Team Priority: 1

At times the User is able to browse but for the most part the error message appears.

User also cannot access Marketplace at times. Error message: "There was an error loading the requested page".

Attachment: Logcat
Haven't been able to reproduce this on Leo using:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/f671fa539473
Gaia   e7e338a765e22334b40ced41489a785941382c66
BuildID 20130411070205
Version 18.0
Attached file logcat 1
Issue still happening on Leo running the following build:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/f671fa539473
Gaia   e7e338a765e22334b40ced41489a785941382c66
Build  2013-04-11-070205

- able to browse for a couple minutes and then hit "Server Not Found" error

attaching 2 logcats if that might help to investigate this issue, 
(Developers setting "Wi-Fi output in adb" was enabled at the time of taking logcats)

***issue is not reproducing on Unagi (no commercial RIL) - able to browse successfully, create email.. etc.
Attached file logcat 2
Assignee: nobody → vchang
I tested in the office and at home on different wifi networks and I haven't hit this issue, and I am using the same build as in Comment 2.

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/f671fa539473
Gaia   e7e338a765e22334b40ced41489a785941382c66
BuildID 20130411070205
Version 18.0

My Home Network is WPA-PSK in case that helps.
Vincent, is there anything in the reported logcats thats worth investigating?   Peculiar that two people both had the same issue with wifi.
(In reply to Tony Chung [:tchung] from comment #5)
> Vincent, is there anything in the reported logcats thats worth
> investigating?   Peculiar that two people both had the same issue with wifi.

I have checked the attached logs, but I doesn't find the error related to wpa_supplicant or WifiWorker. I also try to browser the internet with leo, and it seems work fine for me. Is it related to different build version ?
Attached file busybox binary
To figure out the problem, we can also use ping command to verify if the network and wifi layer are working ok or not. You can follow below steps to push the busybox binary to buri and help to provide more information when the issue is happened again.

1. adb remount 
2. adb push busybox /system/bin

- adb shell busybox ping 8.8.8.8   => ping command 
- adb shell busybox ifconfig wlan0 => check tx/rx bytes  
- adb shell cat /proc/net/route    => check the default route
- adb shell iptables -t nat -nvL   => check if the packets are sent from application to ip layers
mlevin: Are you still able to reproduce using the latest Leo build?

Running on another network here in Spain using:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/5eb76dd7c2a4
Gaia   a7ecc7446b3a15cd3aed1490080de77b3bbdfe6e
BuildID 20130415230205
Version 18.0

Still not able to reproduce this issue. If you are still able to, please follow the steps in Comment 7.
Flags: needinfo?(mlevin)
Marcia,

Issue is ephemeral. 

Some Q Analyst Smoketesters are able to browse via wifi for a while, but when the Leo goes into hibernate mode and they try to browse again it fails to load the sites. Also if they end browser task then wait a while then try to open browser again, it fails to load the sites.

Tested on:
Leo Build ID: 20130416070203
Kernel Date: Mar 15
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/2cc6a1c89a97
Gaia: f8e8f2be6803b02d6a083b2a144a80e7ebf15951
Flags: needinfo?(mlevin)
(In reply to Vincent Chang[:vchang] from comment #7)
> Created attachment 737876 [details]
> busybox binary
> 
> To figure out the problem, we can also use ping command to verify if the
> network and wifi layer are working ok or not. You can follow below steps to
> push the busybox binary to buri and help to provide more information when
> the issue is happened again.
> 
> 1. adb remount 
> 2. adb push busybox /system/bin
> 
> - adb shell busybox ping 8.8.8.8   => ping command 
> - adb shell busybox ifconfig wlan0 => check tx/rx bytes  
> - adb shell cat /proc/net/route    => check the default route
> - adb shell iptables -t nat -nvL   => check if the packets are sent from
> application to ip layers

Vincent,

We are getting permission denied errors. Do you have a solution?  See output:

mlevin@QAnalystsL55 ~
$ adb shell busybox ping 8.8.8.8
/system/bin/sh: busybox: cannot execute - Permission denied

mlevin@QAnalystsL55 ~
$ adb shell busybox ifconfig wlan0
/system/bin/sh: busybox: cannot execute - Permission denied
> Vincent,
> 
> We are getting permission denied errors. Do you have a solution?  See output:
> 
> mlevin@QAnalystsL55 ~
> $ adb shell busybox ping 8.8.8.8
> /system/bin/sh: busybox: cannot execute - Permission denied
> 
> mlevin@QAnalystsL55 ~
> $ adb shell busybox ifconfig wlan0
> /system/bin/sh: busybox: cannot execute - Permission denied

Added chmod 755 command works for me :-)

0. adb root 
1. adb remount 
2. adb push busybox /system/bin
3. adb shell chmod 755 /system/bin/busybox
 
- adb shell busybox ping 8.8.8.8   => ping command 
- adb shell busybox ifconfig wlan0 => check tx/rx bytes  
- adb shell cat /proc/net/route    => check the default route
- adb shell iptables -t nat -nvL   => check if the packets are sent from application to IP layer, check Chain OUTPUT (policy ACCEPT 2 packets, 168 bytes)
type the command :
adb root 

first so that you have root access to the device. You should be able to do pings after that.
Naoki, Vincent,

Leo environment:
Leo Build ID: 20130416070203
Kernel Date: Mar 15
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/2cc6a1c89a97
Gaia: f8e8f2be6803b02d6a083b2a144a80e7ebf15951

At first I was still unable to browse despite Leo saying connected to wifi.

It appeared the ping command was hanging.

Then I woke up the Leo from hibernate (dark screen) and the wifi signal started searching and when it found the wifi network again the ping command worked AND I was able to browse the Interent.

Output:

mlevin@QAnalystsL55 ~
$ adb shell busybox ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes


mlevin@QAnalystsL55 ~
$  adb shell busybox ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:11:22:02:0E:4C
          inet addr:192.168.1.186  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1416 errors:0 dropped:56 overruns:0 frame:0
          TX packets:171 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:173908 (169.8 KiB)  TX bytes:8734 (8.5 KiB)


mlevin@QAnalystsL55 ~
$ adb shell cat /proc/net/route
Iface   Destination     Gateway         Flags   RefCnt  Use     Metric  Mask            MTU     Window                     IRTT
wlan0   00000000        0101A8C0        0003    0       0       0       00000000        0       0    0                     
wlan0   0001A8C0        00000000        0001    0       0       313     00FFFFFF        0       0    0                     

mlevin@QAnalystsL55 ~
$ adb shell iptables -t nat -nvL
Chain PREROUTING (policy ACCEPT 473 packets, 66211 bytes)
 pkts bytes target     prot opt in     out     source               destination

Chain INPUT (policy ACCEPT 41 packets, 6575 bytes)
 pkts bytes target     prot opt in     out     source               destination

Chain OUTPUT (policy ACCEPT 107 packets, 6697 bytes)
 pkts bytes target     prot opt in     out     source               destination

Chain POSTROUTING (policy ACCEPT 107 packets, 6697 bytes)
 pkts bytes target     prot opt in     out     source               destination


After waking up Leo from hibernate mode, screen showed wifi symbol searching for wifi network, then connecting then the ping command worked and I was able to browse the Internet:

mlevin@QAnalystsL55 ~
$ adb shell busybox ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=12 ttl=46 time=38.372 ms
64 bytes from 8.8.8.8: seq=13 ttl=46 time=22.690 ms
64 bytes from 8.8.8.8: seq=14 ttl=46 time=21.545 ms
64 bytes from 8.8.8.8: seq=15 ttl=46 time=22.315 ms
64 bytes from 8.8.8.8: seq=16 ttl=46 time=24.093 ms
64 bytes from 8.8.8.8: seq=17 ttl=46 time=23.340 ms
64 bytes from 8.8.8.8: seq=18 ttl=46 time=24.168 ms
64 bytes from 8.8.8.8: seq=19 ttl=46 time=50.283 ms
64 bytes from 8.8.8.8: seq=20 ttl=46 time=73.345 ms
64 bytes from 8.8.8.8: seq=21 ttl=46 time=96.275 ms

Conclusion could be that the Leo is falsely reporting that it is connected to wifi when it in reality is not connected.
> Conclusion could be that the Leo is falsely reporting that it is connected
> to wifi when it in reality is not connected.

Does it mean that wpa_supplicant failed to report wifi DISCONNECTED event to gecko ?
(In reply to Vincent Chang[:vchang] from comment #14)
> > Conclusion could be that the Leo is falsely reporting that it is connected
> > to wifi when it in reality is not connected.
> 
> Does it mean that wpa_supplicant failed to report wifi DISCONNECTED event to
> gecko ?

Vincent,

I do not know.

Can anyone answer Vincent Chang's question here?
Whiteboard: leorun1
(In reply to mlevin from comment #15)
> (In reply to Vincent Chang[:vchang] from comment #14)
> > > Conclusion could be that the Leo is falsely reporting that it is connected
> > > to wifi when it in reality is not connected.
> > 
> > Does it mean that wpa_supplicant failed to report wifi DISCONNECTED event to
> > gecko ?
> 
> Vincent,
> 
> I do not know.
> 
> Can anyone answer Vincent Chang's question here?

Vincent, i fear that there are binary changes from Leo that they applied to the device, but we dont have those on ours.   is there a way we can tell if if there's a difference?
> Vincent, i fear that there are binary changes from Leo that they applied to
> the device, but we dont have those on ours.   is there a way we can tell if
> if there's a difference?

Right, how can we get the binary from partner in this cause ? Any policy about this kind of bugs.
vchang, is there a way to get the wifi strength?

similar to http://stackoverflow.com/questions/11389492/get-wifi-signal-strength-of-connected-network?  Would we need an API for that?  Can we ask for an API if so?
Oh!  Just realize it's in the wifi log when it scans!

04-25 17:02:39.240: E/wpa_supplicant(822): bssid / frequency / signal level / flags / ssid
Issue does not reproduce for Leo v1.1 Mozilla RIL 
Build ID: 20130426070204
Gecko: 6c2493de1441
Gaia: c9046a7acef33328977840176ff5574720d2c74c
Keywords: smoketest
Currently blocked by bug 866749

On Leo v1.1 Mozilla RIL:
Build ID: 20130430070204
Gecko: 8ca8149ce236
Gaia: b525c25063d33d2e073d9f3e1e1164fadefec998
Keywords: qawanted
No longer blocked by bug 866749.

The Wi-Fi connectivity is currently intermittent, which blocks multiple tests including sending/receiving emails and browsing YouTube.

Leo 1.1 Mozilla RIL
Build ID: 20130502070205
Kernel Date: Mar 15
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/499c3627e89a
Gaia: 495c46489eb256be598a19ea54d7837ce4fc385b
Version #: 18.0
recommending escalation due to impact on smoketests: Pri1
blocking-b2g: --- → leo?
Please have someone in the office take a log cat and force a wifi scan.
Flags: needinfo?(cbarker)
Here you go.
Flags: needinfo?(cbarker)
I see in one of the logs :
05-02 16:27:23.783: I/IdleService(135): Reset idle timeout: tell observer 484e6f90 user is back
05-02 16:27:23.983: I/wpa_supplicant(2802): wlan0: CTRL-EVENT-DISCONNECTED bssid=08:60:6e:22:ae:80 reason=3 locally_generated=1
05-02 16:27:24.023: I/wpa_supplicant(2802): wlan0: CTRL-EVENT-TERMINATING 

reason=3 means “WLAN_REASON_DEAUTH_LEAVING” : Deauthenticated because sending STA is leaving (or has left) IBSS or ESS
I looked around and heard that a work around is to kill the wpa_supplicant;  I'm not sure if that will work... I'll ask the guys to try.
Does it mean that there is a bug related to wpa_supplicant or wifi driver ?
Wait, toggle wifi settings to off also generate CTRL-EVENT-DISCONNECTED with reason=3 message in logcat.
Triage 5/3 - Leo+ per comment 24 - impacting smoketests and also high user impact when encountered.
blocking-b2g: leo? → leo+
(In reply to Vincent Chang[:vchang] from comment #30)
> Does it mean that there is a bug related to wpa_supplicant or wifi driver ?

I am not sure if it's the wpa_supplicant or something like the wifi driver to cause the wpa_supplicant to give the reason 3.  I would need help determining that.  From what I read, it could very well be a driver issue.

After asking one of the guys to do this, it seems they have a more stable connection.  I will check in with him.

Steps to turn kill wpa_supplicant:
adb root
adb shell
ps
(look for the process id for the wpa_supplicant, it should look like : wifi      393  392  2648  1428  ffffffff 00000000 S /system/bin/wpa_supplicant )
kill -9 <process id>  (process id is the first number, in the example 393.  so it should look like: kill -9 393)
ps (to verify that it's no longer running.)
QA Contact: atsai
I cannot reproduce the problem with the newest build I have on leo devices.
Could we set this to tracking w/o leo+?
It doesn't seem the issue still occurs.
QA Contact: atsai
We need more information for further investigating.

Hi Leo Team,
Could you please provide the following information for help?
1. Wi-Fi environment. Such as encryption type, and as much as more information you can provide.
2. Is that possible to get a laptop to connect to the same Wi-Fi and check if it's not a network issue.
3. We need more solid reproduce steps.

Thank you.
Flags: needinfo?(leo.bugzilla.gaia)
no longer reproducable on either v1.1 Comm/Mozilla RILs:
Build ID: 20130506070204
Gecko: 00c554abfc17
Gaia: 9377636cee5ac55b9f1d68f598afc7aadfbb2b00

Resolving as works for me.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Per comment 35, info attached.
1. We are using an ASUS; rt-n66u; WPA2; AES encryption
2. We have have 50 phones and 20 laptops. The Unagis, Inaris, and laptops run perfectly fine; just the Leos cannot maitain a WiFi connection.
3. This issue occurs after @5 minutes of active browsing.

Reopenning issue as unresolved
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(In reply to Stephen Donner [:stephend] from comment #38)
> Created attachment 746706 [details]
> Full logcat of Unagi eng. build with Wi-Fi failure (disconnected)

I reproduced this on my Unagi engineering build (v1-train, today's build), connected to Mozilla Guest, with a sudden disconnect.  kill -9 on the pid did, in fact, get the Wi-Fi working again, as suggested in comment 33.
> I reproduced this on my Unagi engineering build (v1-train, today's build),
> connected to Mozilla Guest, with a sudden disconnect.  kill -9 on the pid
> did, in fact, get the Wi-Fi working again, as suggested in comment 33.

I saw the driver failed message. It is more like a wpa_supplicant or wifi driver issue to me. 
I/wpa_supplicant(  383): wlan0: Trying to associate with SSID 'Mozilla Guest'
I/wpa_supplicant(  383): wlan0: Association request to the driver failed

Can you also have dmesg log ? Also, we can dump more wifi log if you turn on Wi-fi output in adb in settings/Device information/More Information/Developer. You need to restart wifi to take effect.
I found that we may have two default routing entries in routing table when switch between two different routers. 

We can use "busybox ip route" command to check it. 
default via 10.247.24.1 dev wlan0 
default via 10.247.24.1 dev wlan0  metric 313 
default via 10.247.32.1 dev wlan0  metric 313  
10.247.24.0/21 dev wlan0  src 10.247.30.83  metric 313 
10.247.32.0/21 dev wlan0  src 10.247.35.88  metric 313 

Not quite sure if it is related to this bug. When it happened to me, I can't browse the internet. My test environment has two routers, one is connected to internet, the other one is not. When my Leo connects to the router which is not connected to the internet, I can't browse the internet. 

Bug 834573 has fixed two routing entries bug, not sure if someone can help to apply the patch and verify if it helps to fix internet browsing problem.
Blocks: 863441
Who can apply and test bug 834573 to see if it fixes this?
qawanted per comments 41/42
Keywords: qawanted
Vincent: Can you generate a tryserver build with that patch? That would be the easiest way to verify the fix.
Flags: needinfo?(vchang)
I clone the source from http://hg.mozilla.org/releases/mozilla-b2g18 and qimport the patch from bug 834573. Here is the try server url ...

https://tbpl.mozilla.org/?tree=Try

Does it help to verify the fix ?
Flags: needinfo?(vchang)
 I was not able to reproduce this issue. Tried to repro it with multiple Leo builds.
 User is able to browse the internet on Leo device with no interruption.

Leo build ID: 20130528070209
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/611d727390a4
Gaia: 5f499ab1e4a274d3d28e20139c9cdc546dc4fc69
Version 18.0
Keywords: qawanted
Whiteboard: leorun1 → leorun1,RN5/29
Still occurring on a Leo device running the latest build from the mozilla 1.1 branch:

Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/09ac1fd2959c
Gaia: 1cca9324d4444ad28c6fa99875e17abf7e8230be
Build: 20130530070208

The user is able to browse via wi-fi for about two minutes directly after turning it on.  After scrolling through several pages, links, images, etc. the wi-fi connection will stop functioning.  The wifi symbol in the top bar stays on and shows a connection, but the only way the phone will actually use the wi-fi connection is to go in to settings and toggle it off and on.

When attempting to confirm or deny if this bug is still occurring, it is absolutely critical for the tester to use the wi-fi connection for two minutes or more, and be sure to attempt to open several links, pictures, or web pages.  Sometimes the connection will time out earlier, but two minutes is a good starting point.

This bug has failed the smoketest for a very long time now.
This is more like a device specific bug, I can't reproduce the problem using the same Builds in comment 48. Transfer it to vliu and see if he can help to find something interesting.
Assignee: vchang → vliu
Summary: [B2G][Leo][Wifi] Cannot browse using wifi on leo → [B2G][Wifi] Cannot browse using wifi on Leo and Buri
This issue also occurs on the Buri using firmware version 6/6:

Build ID: 20130606070207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/eff45c60396e
Gaia: 337674ef250cc8a05358b873b0fdbb2e73b49224
Platform Version: 18.0
(In reply to Sarah Parsons from comment #50)
> This issue also occurs on the Buri using firmware version 6/6:
> 
> Build ID: 20130606070207
> Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/eff45c60396e
> Gaia: 337674ef250cc8a05358b873b0fdbb2e73b49224
> Platform Version: 18.0

Since I couldn't reproduce this issue on Leo, I will try it on Buri according to your git commit.
(In reply to Sarah Parsons from comment #50)
> This issue also occurs on the Buri using firmware version 6/6:
> 
> Build ID: 20130606070207
> Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/eff45c60396e
> Gaia: 337674ef250cc8a05358b873b0fdbb2e73b49224
> Platform Version: 18.0

I tried to reproduce the issue based on the commit you pointed in comment #50 but still not reproducible. I just connected the Internet via wifi and did surfing in Browser. Did I miss any?
Flags: needinfo?(sparsons)
No longer blocks: 863441
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → WORKSFORME
This is not reproduced on leo device. So this is not a blocker for leo device.
Flags: needinfo?(leo.bugzilla.gaia)
Verified as Worksforme on both Leo 1.1 mozilla RIL and Buri 1.1 mozilla RIL.  Both devices can use the Browser over Wi-Fi without losing their connection.

Build ID: 20130624070224
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/62049a1c5d36
Gaia: 885b874029d8143035765ae903c147a9415fcc52
Platform Version: 18.1
Status: RESOLVED → VERIFIED
Flags: needinfo?(sparsons)
Attached image wifi_screen.png
I am able to connect wifi. It showing connected in UI, But i am unable to browse internet in browser. While browsing it showing "Server not found" error. I am able to ping in the device. PFA screen shot.

Any one suggest what is the issue.
Attachment #8489818 - Flags: feedback?
You need to log in before you can comment on or make changes to this bug.