If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

(SVGZoomAndPan instanceof SVGZoomAndPan) crashes

RESOLVED FIXED in Firefox 22

Status

()

Core
DOM
--
critical
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Jesse Ruderman, Assigned: bz)

Tracking

(Blocks: 1 bug, {crash, regression, testcase})

22 Branch
mozilla23
crash, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox21 unaffected, firefox22+ fixed, firefox23+ verified)

Details

(crash signature)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 736041 [details]
testcase (crashes Firefox when loaded)
(Reporter)

Comment 1

5 years ago
Created attachment 736042 [details]
stack
I can look at this, but it might be a week or so before I get to it.
Assignee: nobody → dzbarsky
Created attachment 736082 [details] [diff] [review]
Fix instanceof for prototype-less interface objects to be saner.

Can you review on a shorter timescale?  ;)
Attachment #736082 - Flags: review?(dzbarsky)
Assignee: dzbarsky → bzbarsky
Note: this is a null-deref crash, but we should still fix on 22.
Blocks: 850958
tracking-firefox22: --- → ?
tracking-firefox23: --- → ?
Keywords: regression
Comment on attachment 736082 [details] [diff] [review]
Fix instanceof for prototype-less interface objects to be saner.

Makes sense.
Attachment #736082 - Flags: review?(dzbarsky) → review+

Comment 6

5 years ago
On Windows: bp-42f5c356-45d8-4643-a37b-be16b2130411.
status-firefox21: --- → unaffected
status-firefox22: --- → affected
status-firefox23: --- → affected
OS: Mac OS X → All
Hardware: x86_64 → All
Version: Trunk → 22 Branch
https://hg.mozilla.org/integration/mozilla-inbound/rev/e1fd922ead11
Flags: in-testsuite+
Target Milestone: --- → mozilla23
Comment on attachment 736082 [details] [diff] [review]
Fix instanceof for prototype-less interface objects to be saner.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 850958
User impact if declined: Null-dereference crashes
Testing completed (on m-c, etc.): Passes the test here
Risk to taking this patch (and alternatives if risky): Very low risk: just a
   null-check. 
String or IDL/UUID changes made by this patch:  Not at all.
Attachment #736082 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/e1fd922ead11
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
status-firefox23: affected → fixed
Comment on attachment 736082 [details] [diff] [review]
Fix instanceof for prototype-less interface objects to be saner.

low risk,a simple null check :) . Approving on aurora.
Attachment #736082 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

5 years ago
tracking-firefox22: ? → +
tracking-firefox23: ? → +
https://hg.mozilla.org/releases/mozilla-aurora/rev/e21a73d26c9f
status-firefox22: affected → fixed
Verified as fixed on Firefox 23 beta 3 (also there are no crash reports in Socorro  with the signatures related to this bug).

Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20100101 Firefox/23.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20100101 Firefox/23.0
Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20100101 Firefox/23.0
Build ID: 20130703181823
status-firefox23: fixed → verified
You need to log in before you can comment on or make changes to this bug.