[Buri][Shira-47973][STK]The ME does not play a beep tone

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+)

Details

(Whiteboard: Poland, IOT, Buri)

Attachments

(1 attachment)

12.13 KB, application/octet-stream
Details
(Reporter)

Description

5 years ago
+++ This bug was initially created as a clone of Bug #434703 +++
 
 Description: 
 The ME does not play a beep tone
 
 
 Customer Impact Statement: 
 The USAT functionality is not working properly.
 
 
 Expected Behaviour: 
 The Play Tone command instructs the ME to play and audio tone.
 
 Upon receiving this command, the ME shall check if it is currently in, or in the process of setting up a speech call.
 
 - If the ME is in, or is setting up a speech call, it shall superimpose the tone on top of the downlink audio (if any), for the duration given in the command. The progress or current state of the call shall not be affected in any way. The ME shall send the TERMINAL RESPONSE (Command performed successfully) as soon as possible after the tone has been completed and, if an alpha identifier was included and displayed, the screen is available for subsequent information display.
 
 - If the ME is not in or setting up a speech call (as in this test case), it shall route the audio to the external ringer, or other appropriate audio device, and play the beep tone for the duration given in the command. The ME shall send the TERMINAL RESPONSE (Command performed successfully) as soon as possible after the beep tone has been completed and, if an alpha identifier was included and displayed, the screen is available for subsequent information display.
 
 Since the alpha identifier provided by the SIM is a null data object (i.e. length = '00' and no value part), the ME should not give any information to the user.
 
 If the alpha identifier is not provided by the SIM, the ME may give information to the user concerning what is happening.
 
 However the behaviour observed on the device under test is different from that stated above and not as per 3GPP TS 11.14 Section 6.4.5
 
 GCF Reference:
 GCF 11.10-4 
 TC 27.22.4.5
 
 
 Terminal Profiles: Proactive UICC: PLAY TONE
 
 TP No: 21
 
 Feature Needed in TMD: RFU
 
 ------
 
 Andreas Utrap <wenzeland>, 03.04.2013:  The issue is that the "general beep" is not heard at all.
 
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #434703 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:

Comment 1

5 years ago
Dear Mozilla,

Please update the status.

Thanks~

Updated

5 years ago
blocking-b2g: --- → tef?
Can you provide the logcat with STK debug enabled? Thanks
Flags: needinfo?(sync-1)

Comment 3

5 years ago
Please test with the latest build when providing this log.

Comment 4

5 years ago
Please also share the PDU used for this TC.
One carrier and one OEM tested and confirmed this works. Please confirm with the reporting party that they are testing this correctly, using a current build.
Status: NEW → RESOLVED
blocking-b2g: tef? → tef+
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

5 years ago
Created an attachment (id=392792)
 QXDM log
Flags: needinfo?(sync-1)
(Reporter)

Comment 7

5 years ago
Created an attachment (id=392791)
 ADB log
(Reporter)

Comment 8

5 years ago
Created attachment 738404 [details]
ADB log

Created an attachment (id=392791)
 ADB log
(Reporter)

Comment 9

5 years ago
setup call APDU:"D0 22 81 03 01 10 00 82 02 81 83 85 0E 44 65 64 69 63 61 74 65 64 20 4D 6F 64 65 86 07 91 33 51 65 36 89 F9";
 play tone APDU:"D0 20 81 03 01 20 00 82 02 81 03 85 0E 49 6E 20 63 61 6C 6C 20 73 65 74 20 75 70 8E 01 01 84 02 01 06";
 the duration time in play tone is 6seconds , but in fact ,TR return after 40 seconds.--->KO1
 and in call process , the tone still play.--->KO2
 as spec ,The progress or current state of the call shall not be affected in any
 way.

Comment 10

5 years ago
I just grabbed this PDU from the logs provided in Comment 8: D020810301200082028103850E496E2063616C6C207365742075708E010184020106

Was able to hear a tone played. Please retest on latest AU.
(Reporter)

Comment 11

5 years ago
yes , I test on AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.19.070;
 Firefox os  v1.0.1;
 Mozilla build ID:20130407070205;
 is it newer than yours?
 and please see the KO detail information in comments.

Comment 12

5 years ago
> the duration time in play tone is 6seconds , but in fact ,TR return after 40 seconds.--->KO1

This was fixed by https://bugzilla.mozilla.org/show_bug.cgi?id=845576 which has been in since AU 056.

I just ran this test using AU072 (although technically your AU070 shouldn't be a problem either as this issue was fixed by 056), I am seeing that the TR is sent immediately after the tone has played (note the timestamps):

1466:04-17 13:22:23.879   436   436 E GeckoConsole: Content JS LOG at app://settings.gaiamobile.org/js/utils.js:20 in debug: [DEBUG # Settings]  STK:Play Tone: {"text":"In call set up","tone":"\u0001","duration":{"timeUnit":1,"timeInterval":6}}
1499:04-17 13:22:28.689   132   132 D RIL_QC_B2G: [0254]> STK_SEND_TERMINAL_RESPONSE 810301200002028281830100

>  and in call process , the tone still play.--->KO2 as spec ,The progress or current state of the call shall not be affected in any way.

The issue you describe here seems to be saying that the tone should not play while the call is in progress. However, from TS 11.14, section 6.4.5, it states:

"If the ME is in, or is setting up a speech call, it shall superimpose the tone on top of the downlink audio (if any), for the duration given in the command. The progress or current state of the call shall not be affected in any way."

Given this, seems like the tone should still play.
(Reporter)

Comment 13

5 years ago
check on latest version
 when keep in call interface , no tone play when execute play tone command , and TR with result '20' = ME currently unable to process command;
 when call in background , tone play normally ,but still have two problem:
 1 the duration not interpret ,in play tone command the duration is 6 seconds , but the TR return until 40 seconds.
 2 TR return with result '20' = ME currently unable to process command, not '00' = Command performed successfully;

Comment 14

5 years ago
Still not able to reproduce. While on a call, when a PLAY_TONE command comes, Settings app is brought to the foreground and I see the popup dialog as well as hear the tone.
Whiteboard: Poland, IOT, Buri
You need to log in before you can comment on or make changes to this bug.