[Buri][Shira-REQ][PL][Browser]Cannot render t-mobile.pl normally

RESOLVED WONTFIX

Status

()

P2
normal
RESOLVED WONTFIX
6 years ago
2 months ago

People

(Reporter: sync-1, Assigned: bugs)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-b2g:-)

Details

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

6 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.19.053
 Firefox os  v1.0.1
 Mozilla build ID: 20130327153857
 
 
 +++ This bug was initially created as a clone of Bug #434713 +++
 
 Created an attachment (id=382186)
 screenshot
 
 DEFECT DESCRIPTION:
 [REQ][PL][Browser]Cannot render t-mobile.pl normally
 
  REPRODUCING PROCEDURES:
 1.connect to wifi
 2.input url t-mobile.pl in address bar of browser,and open the website
 3.check the webpage, find the webpage renders not well,refer to the screenshot.---KO 
 
  EXPECTED BEHAVIOUR:
 The webpage is rendered well.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:5/5
 
  For FT PR, Please list reference mobile's behavior:
 For Telsa orange, this webpage renders well.
 
 ++++++++++ end of initial bug #434713 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:

Comment 1

6 years ago
Created attachment 737332 [details]
screen shot

Comment 2

6 years ago
Created attachment 737333 [details]
screen shot

Comment 3

6 years ago
Created attachment 737334 [details]
screen shot
This may just be text inflation being applied to small text to make it readable, but a Gecko engineer would be able to provide more information.
Component: Gaia::Browser → General

Comment 5

6 years ago
When I zoom in the page, the text area would be large and over the page so I cannot view the page any more.

Updated

6 years ago
blocking-b2g: --- → tef?

Updated

6 years ago
Whiteboard: [tef-triage]
(In reply to Ben Francis [:benfrancis] from comment #4)
> This may just be text inflation being applied to small text to make it
> readable, but a Gecko engineer would be able to provide more information.

Right. This is a font inflation bug.

Andrew - Do you know who could look into this on the gecko side?
Flags: needinfo?(overholt)
(In reply to Jason Smith [:jsmith] from comment #6)
> (In reply to Ben Francis [:benfrancis] from comment #4)
> > This may just be text inflation being applied to small text to make it
> > readable, but a Gecko engineer would be able to provide more information.
> 
> Right. This is a font inflation bug.
> 
> Andrew - Do you know who could look into this on the gecko side?

Probably Scott Johnson or David Baron.  Jet will know so I'll ni? him.
Flags: needinfo?(overholt) → needinfo?(bugs)
blocking-b2g: tef? → tef+
Component: General → General
Product: Boot2Gecko → Firefox
Component: General → Layout
Product: Firefox → Core
Whiteboard: [tef-triage]
We need to get this working on our end for shipping v1.0.1 in Poland.
Rather than ni(jet), I'll assign to him so he can find an owner.
Assignee: nobody → bugs
Flags: needinfo?(bugs)
Created attachment 742485 [details]
screenshot-profile

I'm not confident this is a font inflation bug. See attached screenshot. True, font inflation makes the text very large, and thus the rest of the page unreadable, but even with font inflation disabled, the position:fixed element shows up in the middle of the page, when it should be at the bottom.

Note that this only happens in profile mode. In landscape, it shows up as I would expect (i.e. at the bottom of the page). The only difference being that the user doesn't have to scroll when in profile.
Attachment #737332 - Attachment is obsolete: true
Attachment #737333 - Attachment is obsolete: true
Created attachment 742486 [details]
screenshot-landscape
I'm confused. These screenshots are from an Android device, not a FF OS device.
The font inflation code shouldn't differ between Firefox for Android and Firefox OS.
(That said, handling of fixed positioning might.)
The exploding footer issue manifests in the Android stock and Chrome browsers as well. I also get served desktop content in those browsers so I take it tmobile.pl doesn't have a mobile version. I don't see that there is anything for us to do here.
Upon doing compatibility analysis and with comment 15 - I don't think this is a blocker from a compatibility perspective since:

1. T Mobile has no concept of a mobile site at all with any user agent. I doubt they intended their site to be visited on a mobile browser at all as a result.
2. The issue is also present on FxAndroid, but I haven't heard complaints in our compat meetings about this for months.
3. I question if we can even do anything here, as comment 15 notes.
blocking-b2g: tef+ → tef?
(In reply to David Baron [:dbaron] (don't cc:, use needinfo? instead) from comment #13)
> The font inflation code shouldn't differ between Firefox for Android and
> Firefox OS.

Yes, sorry. I should have been more clear about that.
Based on commnent 16 I'd suggest we dont block
Whiteboard: [tef-triage]
Agree, thanks for additional feedback.
blocking-b2g: tef? → -
Whiteboard: [tef-triage]

Updated

5 years ago
Summary: [Buri][REQ][PL][Browser]Cannot render t-mobile.pl normally → [Buri][Shira-REQ][PL][Browser]Cannot render t-mobile.pl normally

Updated

3 years ago
Blocks: 1258652
Closing as we are not working on Firefox OS anymore.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.