Find in page (in-line search) is inadequate

RESOLVED DUPLICATE of bug 384458

Status

()

Toolkit
Find Toolbar
RESOLVED DUPLICATE of bug 384458
5 years ago
5 years ago

People

(Reporter: gary199301, Unassigned)

Tracking

20 Branch
x86_64
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
The find in page feature in Firefox is highly inadequate. It doesn't provide enough information and ease-of-use.

Let me compare this with Safari's counterpart using some screenshots

As you can see in the screenshots, Safari dims the whole page and highlights all search results. The current result is highlighted with a yellow background for more emphasis. Firefox, on the other hand, just highlights one result, that too with a much less emphasis and it also does not dim the page to focus on the search results.
(Reporter)

Comment 1

5 years ago
Created attachment 736211 [details]
Safari screenshot

This is how the search is done in Safari - easier to see the results and more informative.
(Reporter)

Comment 2

5 years ago
Created attachment 736212 [details]
Firefox screenshot

This is how searching is done in Firefox. Not easy to see the results and not very informative. Very primitive solution to searching.

Comment 3

5 years ago
Provide the website URL, please.
Flags: needinfo?(gary199301)
(Reporter)

Comment 4

5 years ago
(In reply to Loic from comment #3)
> Provide the website URL, please.

This feature request applies to all URLs, as it is a core feature. The specific URL I was using as an the example was "https://www.apple.com/iphone/".
Flags: needinfo?(gary199301)

Comment 5

5 years ago
I don't see where there is the issue. Just click "highlight all" in Firefox findbar.

Updated

5 years ago
Component: General → Find Toolbar
Product: Firefox → Toolkit
(Reporter)

Comment 6

5 years ago
(In reply to Loic from comment #5)
> I don't see where there is the issue. Just click "highlight all" in Firefox
> findbar.

Highlight all works alright, but doesn't really bring out the results. Light green highlight isn't easy to locate, especially on a webpage with a lots of works like Wikipedia. Safari dims the page to bring out the results and uses a much more distinguishable black on yellow background. Even Opera does that. Second, you have to enable Highlight all everytime you search. Third, you also have to disable highlight all once you end the search in order to remove all those pink highlights.

One way of doing it is as soon as you search, by default, the Highlight all feature will be enabled and will automatically disable once the find-in-page dialogue closes.
Yeah, the current find-in-page UI isn't very good, and we'd like to improve it. I'm pretty sure there's an existing bug with some design explorations in it, but I don't know the # offhand.
Whiteboard: [dupeme]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 384458
You need to log in before you can comment on or make changes to this bug.