Received an MMS leaving SMS unusable

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::SMS
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: cajbir, Assigned: Gene Lian (I already quit Mozilla))

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Reporter)

Description

5 years ago
I got sent an MMS message to my Firefox OS phone (running Gaia master and mozilla-central Gecko). The phone got a SMS notification with the text "undefined". Clicking on this took me to the SMS app but no message was there. I assume this is the binary message that gets sent to inform the phone to download an MMS. 

I received a normal text SMS message following that, clicked on the notification, but no messages were listed. Going back to the "contact list view" in the SMS app showed the text of the most recent SMS received but clicking on the contact showed an empty conversation view.
(Reporter)

Comment 1

5 years ago
I can confirm this happens on b2g18 as well. The slight difference is when the binary SMS notification of the MMS arrives, the text is still 'undefined' but clicking on the SMS app shows it in the message list. Clicking on it gives an empty conversation view. 

Any subsequent normal SMS message received gives a notification but does not appear in the SMS conversation view making the SMS application pretty much broken.
status-b2g18: --- → ?
(Reporter)

Comment 2

5 years ago
There appears to be know way to recover from this. If I try to delete the message thread the phone hangs on the "Deleting" screen.
(Assignee)

Comment 3

5 years ago
I've been suggesting we should disable the MMS function until we can make sure the Gaia is supported for sure and receiving MMS doesn't break any functions.
Blocks: 744684
(Reporter)

Comment 4

5 years ago
I think it would be good to at least handle the SMS notification message so that it doesn't come up as 'undefined' or break the SMS app. At the moment I can't dogfood B2G anymore since I often receive SMS messages from friends on Android phones that automatically convert the SMS to an MMS if they pass the SMS character count. I then get this breakage and looks like I'll have to reflash.
(Assignee)

Updated

5 years ago
blocking-b2g: --- → leo?

Updated

5 years ago
status-b2g18: ? → affected
Gene, who's the right person to assign this to?
blocking-b2g: leo? → leo+
status-b2g18: affected → ?
Keywords: regression, regressionwindow-wanted

Comment 6

5 years ago
Gene, we have to make MMS working after 4/22, and this bug will also be fixed at the same time. 
You can close this bug after finishing MMS functions.
Assignee: nobody → gene.lian
I think it require a clear flow to handle this sms notification. This notification is used to notify the user that mms message is pending on the server because default mms retrieval mode is "manual". The complete scenario for manual mode might be:
1. User receive a text notification and said "mms message is pending on the server.Please click here to download the message."
2. After click message to download, user should receive the mms message in sender's message thread.
This could be gaia effort, but we need UX to provide wireframe.
(Assignee)

Comment 8

5 years ago
Adding [NO_UPLIFT]. Just making sure all the MMS bugs have this tag for now.
Keywords: regression, regressionwindow-wanted
Whiteboard: [NO_UPLIFT]

Updated

5 years ago
status-b2g18: ? → ---

Comment 9

5 years ago
Gene, can we close this bug now?
Flags: needinfo?(gene.lian)
(Assignee)

Comment 10

5 years ago
I'm testing on this. Please stay tuned.
Flags: needinfo?(gene.lian)
(Assignee)

Comment 11

5 years ago
The latest codes work fine. Closing this issue.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Whiteboard: [NO_UPLIFT]
You need to log in before you can comment on or make changes to this bug.