High CPU usage with long multi-day event

REOPENED
Unassigned

Status

REOPENED
6 years ago
29 days ago

People

(Reporter: trevmrgn+bug, Unassigned, NeedInfo)

Tracking

(Blocks: 1 bug, {perf})

Lightning 1.9.1

Details

(Whiteboard: dupeme?)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557

Steps to reproduce:

Create a multi-day all-day event lasting longer than 6 days, starting today.

To confirm, I tried on a new thunderbird profile with only lightning installed.


Actual results:

CPU usage went up to 50% (on dual CPU PC)

Usage goes back to normal if Today Pane is moved to another day, but not if it's hidden or switched to tasks only.
Also goes back to normal if containing calendar is hidden.
(Reporter)

Comment 1

6 years ago
Six days after finding this bug, both Thunderbird and Firefox started using 50% CPU each (even without extensions).  Restarting them didn't help.  Lightning 
Restarting windows cured the problem.

I'm thinking there may be a timing problem related to how long windows has been running (I rarely reboot - just hibernate overnight & weekend).  e.g. an interval timer that uses a 32-bit millisecond counter in its core without allowing for overflow.  That would correspond with the total time that windows has been running

I'll report back in a few months when I see whether it happens again.

Updated

6 years ago
Keywords: perf
Whiteboard: dupeme?

Comment 2

4 years ago
Trevor, does this still reproduce for you?
Flags: needinfo?(trevmrgn+bug)

Comment 3

3 years ago
I'm not able to reproduce and Trevor seems to be gone
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(trevmrgn+bug)
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

3 years ago
I have not seen this happen again, but I don't think I have had windows running without reboot for the suspected 50 days since the original report.
I'll leave the status 'INCOMPLETE' unless I see it again.
I believe I filed another issue on this, but indeed we have a perf issue for long running events. For effects, try creating an event that lasts 50 years. You'll have Lightning hang for a while. Reopening until the other bug report is found.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INCOMPLETE → ---

Updated

3 years ago
Blocks: 441710

Comment 6

29 days ago
(In reply to Philipp Kewisch [:Fallen] [:📆] from comment #5)
> I believe I filed another issue on this, but indeed we have a perf issue for
> long running events. 

Perhaps you are thinking of Bug 796853 - Recurring Event with long duration hangs Lightning?
That was duped to bug 680620 which has a patch and is assigned to you :)

Pehraps also related?
* Bug 362987 - Large calendars with many recurring items slow down the app
* Bug 848024 - Lightning CalDAV calendar with thousands of events makes Thunderbird+Lightning very slow
Flags: needinfo?(philipp)
You need to log in before you can comment on or make changes to this bug.