If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

fix the taloserror handling when we process a crash

RESOLVED WORKSFORME

Status

Testing
Talos
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: jmaher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
from tbpl logs:
0x662e3000 - 0x66333fff  libnssckbi.so (deleted)  ???

    main()
  File "run_tests.py", line 328, in main
    run_tests(parser)
  File "run_tests.py", line 277, in run_tests
    talos_results.add(mytest.runTest(browser_config, test))
  File "/builds/panda-0821/talos-data/talos/ttest.py", line 404, in runTest
    self.cleanupAndCheckForCrashes(browser_config, profile_dir, test_config['name'])
  File "/builds/panda-0821/talos-data/talos/ttest.py", line 170, in cleanupAndCheckForCrashes
    raise talosCrash()
TypeError: __init__() takes exactly 2 arguments (1 given)
(Reporter)

Comment 1

5 years ago
this would make a good first bug.

Updated

5 years ago
Duplicate of this bug: 864113
Can I take up this bug?
(Reporter)

Comment 4

4 years ago
this might not even be a bug anymore- yes, please take a look at this and see if it still happens.  You can get talos running and kill the process to invoke a crash.  I believe on linux it is 'kill -ABRT <pid>'
QA Contact: vaibhavmagarwal

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.