Crashes when viewing HTML E-mails

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: info, Unassigned)

Tracking

({crash})

SeaMonkey 2.13 Branch
x86
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

30.20 KB, application/octet-stream
Details
(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_5_8) AppleWebKit/534.50.2 (KHTML, like Gecko) Version/5.0.6 Safari/533.22.3

Steps to reproduce:

Clicking on an e-mail in my inbox list.


Actual results:

It attempts to open and HTML e-mail, then it then crashes. This has been happening for about 2 months now and is making work difficult. Only some HTML e-mails crash it, others open fine.


Expected results:

The e-mail should have opened. It appears there is a corrupt plist file or something because the same thing is happening to TextEdit and another app I can't even think of right now. Is there a common library between SeaMonkey and TextEdit that you know of that might help me narrow down the reason for these repeated crashes? It seems there is some problem with the rendering of only certain HTML as some HTML e-mails actually open fine. Text e-mails open fine. Any help would be appreciated as I have used SeaMonkey (and before Netscape Communicator) for as long as I can remember for e-mail and would like to continue to do so (and may be updating my OS from Mac OS 10.5.8 to 10.6.4+ soon so I can update SeaMonkey further). This issue seems to be something corrupted on my system since it affects more than one application. I've tried downloading a fresh copy of SeaMonkey and then still use my existing account's e-mails but that didn't help, then I copied my whole account folder in and that didn't help either. So corrupt plist or something I can delete and it be regenerated?

I've submitted this as a bug to get specific, quick support and not a lot of guesses from other users as my case doesn't seem like something standard.

Thanks.
1. SeaMonkey 2.13 is obsolete and Safari is of no interest to Mozilla developers. Please upgrade to SeaMonkey 2.17 or later.
2. Next time it happens, please (on restart) save a copy of the offending email (File → Save As → File) and attach it to this bug.
3. Please also browse to about:crashes, and paste into the comment to the attachment (step 2) the name of the corresponding crash (highlight the bp-something name with the mouse in the about:crashes page, then Edit→Copy, then paste it into the comment to the attachment).
Severity: normal → critical
Component: General → MailNews: Message Display
Keywords: crash
(Reporter)

Comment 2

6 years ago
Created attachment 736601 [details]
e-mail that crashes SeaMonkey
(Reporter)

Comment 3

6 years ago
1. I can't yet upgrade because I have a lot of work going on and you no longer support Mac OS 10.5.8. I don't think I mentioned Safari, just TextEdit as both TextEdit and SeaMonkey started crashing when opening things with HTML at the same time, that's why I'm thinking it's some shared plist library or something that is corrupted.

2. I've attached an e-mail that crashes SeaMonkey (one of many).

3. Here is a list of all the crashes I've reported that show up in about:crashes, with the topmost being the report from the crash e-mail that is attached:

Report ID   Date Submitted
      
    
    
bp-7add9764-0d17-4aa8-9c8b-26f842130412 2013/04/11 9:37 PM
bp-98d1930d-48cf-4884-8da2-88dee2130411 2013/04/11 1:50 PM
bp-40c1d45d-5ccd-4896-ae3c-aae9b2130411 2013/04/11 1:50 PM
bp-97bd5f04-00e2-4a1e-b71a-ecabc2130411 2013/04/11 1:49 PM
bp-151223b8-4b30-48d4-8d6f-f3ee32130411 2013/04/11 1:49 PM
bp-b66ae0d4-83d5-4038-a505-a888d2130411 2013/04/11 1:46 PM
9E508734-3DEE-4AC1-934C-151F026F81D9 2013/04/11 1:44 PM
bp-590c7eb6-fb62-46ab-be7a-fcfb52130411 2013/04/11 1:44 PM
bp-7dea56f3-0386-492b-a79e-73acf2130411 2013/04/11 1:43 PM
bp-ad2a4c52-3c61-4e9e-80d7-d0f342130411 2013/04/11 1:42 PM
bp-ae4922d7-07d1-48d1-af4d-9a8d92130411 2013/04/11 1:42 PM
bp-350c6a1f-0879-4b9b-98c6-755372130411 2013/04/11 12:56 PM
bp-d18646de-4ff9-4483-8afb-7d36e2130411 2013/04/11 12:56 PM
bp-a221ddb5-77b4-4e99-b22e-02fc72130411 2013/04/11 12:51 PM
7438728D-1CA2-4C9B-A34C-A33865CBD7F0 2013/04/083:02 PM
bp-8156ff78-54dc-4cf9-852f-6f1262130406 2013/04/06 11:55 AM
bp-486b590b-4541-486a-9d1e-8a5bf2130406 2013/04/06 11:54 AM
bp-7c0898e9-03f7-48d6-a706-8b6c12130406 2013/04/06 11:54 AM
bp-6aadaddd-0481-4bce-9c93-524532130406 2013/04/06 11:52 AM
bp-615f5e20-4f58-4bf3-b253-b03222130406 2013/04/06 11:52 AM
bp-32083308-64d0-4565-8c37-6351f2130405 2013/04/04 8:19 PM
bp-4e9bfc14-5f31-4488-bbf1-765332130405 2013/04/04 8:19 PM
bp-b24b68e0-1d70-4985-a024-6d6892130405 2013/04/04 8:19 PM
bp-e7998ebb-907f-49b4-96e7-b54452130405 2013/04/04 8:18 PM
bp-6e9a9a18-0c0d-4693-bc48-e57892130403 2013/04/03 8:15 AM
bp-ce455577-d5fa-41e2-b1b1-10c692130403 2013/04/03 8:02 AM
bp-a3229560-e18d-452f-8e09-935a62130402 2013/04/02 5:44 PM
bp-42bbe48c-f051-4e00-ab08-9d1cb2130402 2013/04/02 8:43 AM
bp-b8051c29-ff8b-4bd0-bd76-3ba222130331 2013/03/31 12:44 AM
bp-a56f5e6f-3948-46dc-9449-ed2792130330 2013/03/30 2:54 PM
bp-e7a7a458-3606-4179-9d07-0dbf32130330 2013/03/30 2:49 PM
bp-9db3792b-e6c1-4aa4-b45e-6c2fb2130330 2013/03/30 2:49 PM
bp-e489f455-dd07-4424-87b2-a21b12130329 2013/03/29 1:25 PM
bp-72807a40-9e72-4011-8474-247b12130329 2013/03/29 1:24 PM
bp-30955169-8be8-47f2-bb79-5f0982130329 2013/03/29 1:24 PM
bp-a68ee475-b63b-413c-9f7f-be8222130329 2013/03/29 1:24 PM
bp-dce01a71-5306-4fbd-a644-59cf22130329 2013/03/29 12:11 PM
bp-24e16d32-ecee-4c0d-bbd0-629272130329 2013/03/29 12:06 PM 
bp-6a584a4e-38d7-450d-bebd-12d612130329 2013/03/29 12:06 PM
bp-090bfd75-6054-42a9-a51d-b0ced2130329 2013/03/29 12:06 PM
bp-230f59a0-b37d-4c3f-b3c2-91ac42130329 2013/03/29 12:05 PM
bp-8b14d5cb-b353-4612-a933-50b942130329 2013/03/29 12:05 PM
bp-f4f854da-b031-4018-897d-f552d2130329 2013/03/29 12:05 PM
bp-5c08be86-2b2f-4947-887d-633342130329 2013/03/29 12:04 PM
bp-7a04c783-4e9c-4c75-b405-92e582130329 2013/03/29 12:02 PM
bp-dc2f0fa6-9e8f-45eb-a636-e1e582130322 2013/03/22 5:32 AM
bp-0f98e001-322d-4480-8068-a8e902130322 2013/03/22 5:32 AM
bp-45368782-283e-468e-9989-9b2242130322 2013/03/22 5:32 AM
bp-76b97297-0051-4442-a5fd-926022130322 2013/03/22 5:31 AM
bp-af9c1428-2989-4ee1-8551-90ccf2130322 2013/03/22 5:31 AM
bp-b59d6f66-0340-4081-a6b2-b32b02130322 2013/03/22 5:31 AM
bp-9ac84072-d1fa-40f2-abc4-ef7172130322 2013/03/22 5:31 AM
bp-55bd5b6e-2181-42da-945a-bc4e02130322 2013/03/22 5:31 AM
bp-9585d3df-84ab-484b-b0f5-8bc8c2130322 2013/03/22 5:31 AM
bp-720efb0c-6270-4ed3-b3ba-d37572130322 2013/03/22 1:03 AM
bp-b3551d03-da32-467c-8932-94e8f2130322 2013/03/22 1:03 AM
bp-e9805fd0-c48f-459c-b83c-efdef2130322 2013/03/22 1:03 AM
5907781F-2781-4563-BB0A-B7FD77C31A18 2013/03/22 1:03 AM
bp-9ab9ca9b-84e1-487e-b39a-ed5722130322 2013/03/22 1:02 AM
bp-5773c2c0-a5d5-4fa5-8702-80edf2130322 2013/03/22 12:56 AM
bp-68691fb5-57e1-4fcf-888f-365d12130322 2013/03/22 12:56 AM
bp-e8730511-19f9-4144-b881-4f2c32130322 2013/03/22 12:55 AM
bp-bf3ea8a2-0dc1-4948-a6a0-eeda82130322 2013/03/22 12:55 AM
bp-165c50a9-0be4-4a8f-aa5d-5f6f02130322 2013/03/21 11:28 PM
bp-25b8015c-c0e9-4162-bbbe-88fb12130321 2013/03/21 6:29 PM
bp-abd77a83-ac20-4351-861f-1e8d42130321 2013/03/21 4:43 PM
bp-6d1d92db-b606-49a9-824a-515c12130321 2013/03/21 4:41 PM
bp-6e885409-4ab3-4c83-b753-a79af2130315 2013/03/14 11:40 PM
bp-5aa1f74c-d020-4e4c-9208-e049e2130315 2013/03/14 11:40 PM
bp-f34e104a-3b5b-47da-9de6-6bcb12130315 2013/03/14 11:38 PM
bp-62f99bdb-e5b0-49fb-9c71-5704b2130314 2013/03/13 10:52 PM
bp-09a8b4cf-220e-498d-b004-72ff92130313 2013/03/13 7:24 PM
bp-fb69fc09-508d-4061-b8a3-bba522130313 2013/03/13 7:23 PM
DA85F40E-E480-498E-A09A-2A2EA5D1C0DB 2013/03/13 7:19 PM
bp-200ac644-6e08-4371-a78f-60a682130313 2013/03/13 3:57 PM
bp-459c06ee-3d52-4281-93ff-000b52130313 2013/03/13 3:57 PM
bp-756af9ea-62e2-4fab-b488-f66172130313 2013/03/13 3:57 PM
bp-811bc82a-59f0-4db3-a996-99d202130313 2013/03/13 3:56 PM
1F597C6D-B029-4A37-888B-99F67B3C1148 2013/03/13 3:56 PM
bp-312ce9af-eadd-45cc-9200-73a092130313 2013/03/13 3:55 PM
bp-af8739e1-686e-4d1a-898c-899102130313 2013/03/13 3:54 PM
bp-de548cd5-b89d-48e6-9de0-914ac2130313 2013/03/13 3:54 PM
bp-cf4be260-3e5d-4ecf-832e-a6b202130313 2013/03/13 3:44 PM
bp-2fcfdfbf-0b3e-4727-b6f5-0e2c92130313 2013/03/13 3:44 PM
bp-49c411bf-7609-480e-97db-347772130313 2013/03/13 3:43 PM
bp-fc9cff72-413c-4c2f-9ae8-877732130313 2013/03/13 3:43 PM
bp-c9e6b280-59eb-4a8d-9db1-87c7a2130313 2013/03/13 3:43 PM
bp-4ec96b45-5171-41d0-ba1a-212c42130313 2013/03/13 3:34 PM
bp-c44d18ac-9c3e-4a3e-a943-9fa292130313 2013/03/13 3:33 PM
bp-6d2093b4-f0ef-4946-963c-671d72130313 2013/03/13 3:33 PM
bp-8023b752-aedd-4b5c-b51d-5189b2130313 2013/03/13 3:33 PM
bp-bd5aca05-eb45-4f26-8f68-6d6872130313 2013/03/13 3:32 PM
bp-91e39476-93ea-4062-8436-394372130313 2013/03/13 2:55 PM
bp-9c46dbb3-b4ea-4d70-9e41-557ac2130313 2013/03/13 2:42 PM
bp-0a6d6821-9469-4266-85f4-2534b2130313 2013/03/13 2:42 PM
bp-5de12223-f463-4cb4-8cb3-0a2ab2130313 2013/03/13 2:42 PM
bp-0e42878c-bd7e-4a2a-93d4-a0e8e2130313 2013/03/13 2:09 PM
bp-1065e18f-dd70-4c07-af22-dd0ae2130312 2013/03/12 4:24 PM
bp-15121186-640d-4147-a69f-52b4f2130312 2013/03/12 3:39 PM
bp-b4f09800-174a-436e-851e-51d672130304 2013/03/04 4:02 AM
bp-31ec9277-1c27-480e-a6e3-34e7e2130304 2013/03/04 3:55 AM
ECF558A8-1D90-4CB5-A1EF-6340E314D576 2013/03/04 3:55 AM
5622B44D-C085-4963-A146-5D8696B97333 2013/03/04 3:51 AM
bp-9ed17890-6795-4b89-a16f-174882130304 2013/03/04 3:43 AM
bp-214795d2-2553-40c8-9ea8-e45522130304 2013/03/04 3:42 AM
bp-f812d547-f056-4ff0-8b70-54e2f2130303 2013/03/03 5:36 PM
bp-afcd9c29-0aeb-4a7d-9e9c-5b3c82130228 2013/02/27 10:48 PM
674A711C-7E4D-480F-B71E-8B90FE0CBB38 2013/02/27 10:48 PM
bp-92bff903-897f-4d11-867b-4f5c02130227 2013/02/26 11:20 PM
bp-0140cf64-35d5-4a8f-92a8-f0b7a21302272013/02/2611:15 PM

Comment 4

6 years ago
Sorry SeaMonkey 2.13 is not supported any more. Is your Mac a PPC or Intel Mac?

Comment 5

6 years ago
Intel, according to UA string.
Looking at bug reports it seems that problem was fixed either in next release (SM 2.14/FF 17.0) or in newer OS (10.6 or above) as all reports happens in OS X 10.5 and highest reported versions for SM/FF are 2.13.2/16.0.2. Also, there are no bugs with TAATMorphSubtableMorx found in Bugzilla so fix was unintended. One thing you can try if OS upgrade is not possible now is to turn off Hardware acceleration.
(Reporter)

Comment 6

6 years ago
Thank you Phoenix. That was exactly the kind of information I was hoping for, something fairly definitive to my exact problem. I still think something was corrupted as everything was working fine until one day SeaMonkey just crashed and after that it did it regularly as well as TextEdit having the same symptoms.

Thank you for your time and expertise in the matter. I've been holding out for a long time since I wasn't able to upgrade Mac OS because my Adobe CS3 apps wouldn't work, but now I've found through research that Apple made some fixes and I can upgrade, so I can then upgrade SeaMonkey as well. Just need to find the time to do a clean install on a new clean drive.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
In reply to comment #3:

Thank you for all the crash links, especially the one which goes with the attached email.

The reason I mentioned Safari is that you used it to report the bug. When you report the bug with the exact browser and version on which you saw the bug, the "User Agent" at the top of the "Description" (comment zero) in the bug report gives some iformation about that browser, which developers can use to try and find between which source changes the problem appeared. In the case of a crash bug, the same information is part of each crash report, so nothing was lost here, only delayed.

Happy browsing after you upgrade, but do you really need a new drive? Can't you just trash the old SeaMonkey installation and get an up-to-date one from the current version of the .dmg ? Well, I wish you all the best anyway.
(Reporter)

Comment 8

6 years ago
I generally user SeaMonkey for e-mail and Safari for browsing, it's just my preference.

Well, when I do a clean install of a new operating system and do a clean install of all apps, I'm hoping to upgrade to a 6G solid state drive from Other World Computing as I've been running on the same drive for a year or two now and will shift the old drives down into the raid as I have 4 externals as-is. My reason for not just installing a new version of SeaMonkey is because my current Mac OS 10.5.8 is no longer supported by newer versions of SeaMonkey so I can't just simply update/upgrade as I've done for years.
You need to log in before you can comment on or make changes to this bug.