Closed Bug 860836 Opened 7 years ago Closed 7 years ago

Error importing contacts from SIM card

Categories

(Firefox OS Graveyard :: General, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:tef+, firefox21 wontfix, firefox22 wontfix, firefox23 fixed, b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 fixed)

VERIFIED FIXED
1.0.1 Cert2 (21may)
blocking-b2g tef+
Tracking Status
firefox21 --- wontfix
firefox22 --- wontfix
firefox23 --- fixed
b2g18 --- fixed
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- fixed

People

(Reporter: dpalomino, Assigned: gwagner, NeedInfo)

References

Details

(Whiteboard: IOT, Chile, Spain, Ikura, khepera_43608)

Attachments

(6 files)

Buildid "20130321070205", device: ikura
gecko commit: b5183c99228bdc5be33340e359efd1b4f0859e92 
gaia commit: 577d13088ebdbd353d13910d3317e713a140415b

Reported in certification as a blocker (for both LatAm and Spain). Adding dep and nominating. 

Importing from a SIM card does not succeed, and it the process is stopped. 

In log attached, the steps followed are: 
1. User a SIM card with big amount of contacts (148 in the log)
2. Import contacts from SIM card
3. Process start ok, progressing bar goes on fine
4. At 34/148 imported contacts, the process is frozen and does not continue (it's importing 34th contact for ever)


1. Enter a SIM card with many contacts (e.g. 148 entries filled)
2.- Import contacts from SIM to phone
3.- It starts copying but progress bar is frozen before finishing (e.g. 34/148)
4.- Wait 5 minutes in this screen to assure that the importing is stopped
5.- Press the home button to exit from the contacts app and close it
6.- Enter again in contacts app and check the contacts copied (33 contacts)

It's possible to exit from the app. 33 contacts has been imported.
Attached image screenshot
blocking-b2g: tef? → tef+
David, are you in Madrid next week? I can't see anything obvious in the logcat but it would be good to use your SIM card with our debug flag enabled.
Nivi, this was run using commercial RIL so wondering if you could take a look?
Assignee: nobody → nsarkar
Flags: needinfo?(nsarkar)
David, which AU was used for the test?
Flags: needinfo?(dpv)
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Whiteboard: IOT, Chile, Spain, Ikura
Hi Anshul, 

According to ZTE info: 
AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.19.046
Flags: needinfo?(dpv)
Hi David/Anshul,
I will take a look and see what's going on here. Can they reproduce the issue on the lastest AU as well?

Nivi.
Flags: needinfo?(nsarkar)
Hi,

I did try to import contacts from a card with empty contacts in between and was able to do it but I had only 11 contacts.(tested with latest code.)
Could someone send me the radio logs along with the main log? Please use - |adb logcat -v threadtime -b main -b radio| to collect all logs.

Also, the last column (Column D) from the excel sheet having the contacts data doesn't have a header? Does anyone know what that means? I see that for the 34th contact, the value for column D is Si` (yes) whereas all other records have the value no. That's one difference I notice. Don't know if that's an issue? Could someone please confirm.

Nivi.
Whiteboard: IOT, Chile, Spain, Ikura → IOT, Chile, Spain, Ikura, khepera_43608
Does not seems like a Gaia bug. Moving to 'general' to reflect that.
Component: Gaia::Contacts → General
(In reply to Gregor Wagner [:gwagner] from comment #3)
> David, are you in Madrid next week? I can't see anything obvious in the
> logcat but it would be good to use your SIM card with our debug flag enabled.

Hi Gregor!

Yes, I'm in Madrid now. The SIM card used is from testing house, it's not our SIM. However testing house office is also in Madrid. 

Thks!
David
Can we ask at least what's the content (in plain text) of that contact? What does the last column in the excel mean?
Flags: needinfo?(dpv)
Could someone send me the adb logs (main and radio)? Since the export contacts screen already shows the total number of contacts (148) and gets stuck importing at record no 34, I would say that RIL (commercial) has already sent the complete list of contacts to gaia. It might be a gaia bug. Vivien, how did you rule this out as not being a gaia bug? I am curious.(In reply to Vivien Nicolas (:vingtetun) (:21) from comment #9)
> Does not seems like a Gaia bug. Moving to 'general' to reflect that.
Whiteboard: IOT, Chile, Spain, Ikura, khepera_43608 → IOT, Chile, Spain, Ikura, khepera_43608 [NPOTB]
Dietrich, I think comment 12 raise some concerns about whether this is a commercial bug or not. I'd suggest we remove NPOTB until it is confirmed.

David, can we get that SIM Card?
I will be in Madrid for two more days so would be happy to help debug the issue.
Anshul, Did you get a chance to get hold of the SIM card?
No I didn't. David, can you please help me find the SIM card?
Hi, 

As commented f2f, SIM card is not available (it was not tested in Madrid). We're requesting a dump of this SIM card, I hope to have it soon.
Flags: needinfo?(dpv)
ni?(dpv) while we await the dump.
Flags: needinfo?(dpv)
Hi, 

We've requested it again, but dump not received yet. 

Sorry about that. 
David
Flags: needinfo?(dpv)
Reviewed on April 23th: 
    Asking for new logs, but no reply yet. 
    Can't reproduce this issue in house. AT4 can reproduce this issue. 
    Will provide the logs by the end of tomorrow. Also suggest to check the latest build. 
    Agreed to have this fixed before the 3rd certification.
Hi, 

Please, find attached the new log about the issue reported. 

Thanks!
David
Flags: needinfo?
Target Milestone: --- → 1.0.1 Cert2 (28may)
Hi David,

Is this log from commercial RIL? Seems like it's not. Could you please confirm?
Also, if you are using reference ril, do you see the previous behavior (import contacts screen stuck for contact 34) or a crash?

Nivi.
Flags: needinfo?
Target Milestone: 1.0.1 Cert2 (28may) → ---
Hi, Nivi, may I know if there has any specific reason that you removed the target milestone? Thanks.
Flags: needinfo?(nsarkar)
Khu, that might have been a mistake. I added it back.
Flags: needinfo?(nsarkar)
Target Milestone: --- → 1.0.1 Cert2 (28may)
Hi, 

Yes, sorry about that, we forgot to comment this. A new log was requested with Moz RIL just to check wether the issue was related to RIL or gaia/gecko. As it is reproduced with both RIL, I guess it's not caused by RIL. 

Do we need any other specific logs to investigate further this issue?

Thanks, 
David
Alberto, Francisco, can you have a look at the logs? Based on comment 25 it seems not to be a RIL issue.
Flags: needinfo?(francisco.jordano)
Hi folks, after checking the last log provided and there is no a single line regarding gaia, everything is related to the RIL.

Will provide a version of gaia with verbose comments when SIM import, at least to see if we are able to detect the error in the frontend.

Thanks!
F.
Flags: needinfo?(francisco.jordano)
Hi Francisco, 

In the first log attached it should be included, aren't there?

Please, let us know if we need more logs here. We don't have the SIM card where they are reproducing the bug, so we've to ask to testhouse to collect new logs if needed. 

Thanks!
David
Assignee: nsarkar → nobody
May I know is there anyone knows where the issue locates? It looks like it's in RIL. Anshul, could we have your comments here? Thanks!
Khu, at this point it doesn't seem like the issue is in RIL as the issue is seen both with Moz ril and commercial RIL. We haven't been able to replicate the exact scenario and so not able to debug any further. 

I am hoping Francisco can shed some more light on the issue.
Would it be a good idea to just get a USB SIM reader/writer and write a ton of contacts to a SIM ourselves to test this?
(In reply to Anshul from comment #30)
> Khu, at this point it doesn't seem like the issue is in RIL as the issue is
> seen both with Moz ril and commercial RIL. We haven't been able to replicate
> the exact scenario and so not able to debug any further. 
> 
Thanks! Ken, do you have any comments on this bug? I think the 1st step would be: try to reproduce this issue in house or check the attached logs.
Flags: needinfo?(kchang)
Al, can you help to reproduce this issue? Thanks.
Flags: needinfo?(atsai)
Keywords: qawanted
D/RILC    (  117): qcril_uim_read_record_resp: token=125 qmi_err_code=0 
D/RILC    (  117): RIL_SIM_IO_Response: sw1=0x90 sw2=0x0 data=434f4e545241544f2035ffffffff068136887468f5ffffffffffffff
....
D/RILC    (  117): qcril_uim_read_record_resp: token=374 qmi_err_code=0 
D/RILC    (  117): RIL_SIM_IO_Response: sw1=0x90 sw2=0x0 data=ffffffffffffffffffffffffffffffffffffffffffffffffffffffff
I saw RILC had tried to read all contacts(374-125+1=250) from modem, which means that RIL had received the ICC Contacts without error.

Need David's help to provide what Gregor requested in comment 3 to know if contact manager receives those contacts from RIL.
Gregor, did you get any clue in Madrid work week?
Flags: needinfo?(kchang) → needinfo?(dpv)
Flags: needinfo?(anygregor)
Hi,

just pushed a branch, from master, that adds lots of logging to the sim import.

Here you can download it:

https://github.com/arcturus/gaia/tree/sim_import_log

Please, can someone with access to the SIM flash a phone with this branch and send the logcat generated?

Thanks,
F.
(In reply to Francisco Jordano [:arcturus] from comment #35)
> Hi,
> just pushed a branch, from master, that adds lots of logging to the sim
> import.
> Here you can download it:
> https://github.com/arcturus/gaia/tree/sim_import_log
> 
> Please, can someone with access to the SIM flash a phone with this branch
> and send the logcat generated?
I will request my colleagues to create a specific build with this branch
  --> Firefox_Mozilla@126.com, could you please do this?

Once I get the build I will request the lab to repeat it and take logs.

thanks
Flags: needinfo?(Firefox_Mozilla)
> Need David's help to provide what Gregor requested in comment 3 to know if
> contact manager receives those contacts from RIL.
> Gregor, did you get any clue in Madrid work week?

Hi Ken, 

This issue was tested by the testhouse, in the offices out of Madrid. I'll try to request them to send us the sim card to Madrid, so we could test this easier. 

Thanks!
David
Flags: needinfo?(dpv)
I'm not entirely sure what anyone on QA can do here - there's not enough information to move forward here with any level of QA analysis. I would need the following information from David:

- What type of SIM reproduced this bug?
- Does TEF QA (i.e. in Madrid) have the ability to get access to a SIM of this type?

Given that this was tested in Madrid with a particular SIM, my first guess is that we should ask someone from TEF QA to look into this when we know the above information.
Flags: needinfo?(atsai) → needinfo?(dpv)
Adding the logcat generated while importing the contacts on a inari device with:

ZTE build id: 20130506003326
gaia commit: eeb713b657
QC RIL: V1.01.00.01.019.094
Flags: needinfo?(dpv)
(In reply to Carlos Martínez Toral [:carlosmartinez] from comment #39)
> Adding the logcat generated while importing the contacts on a inari device
> with:
> 
> ZTE build id: 20130506003326
> gaia commit: eeb713b657
> QC RIL: V1.01.00.01.019.094

I deny my own words, testing was finally done on a inari device, using a ZTE Eng build (P752D04_TME_ENG_FOR_PARTENER_20130426) and gaia coming from https://github.com/arcturus/gaia/tree/sim_import_log.

ZTE build id: 20130426093145
gaia commit: 28a84f1
QC RIL: V1.01.00.01.019.085

Logcat added.
I'm guessing your comment implies that you've reproduced this on a 4/26 build, right? If so, then the qawanted request has been met to confirm a reproduction.
Keywords: qawanted
That might be it:
["PRIVE70"],"honorificPrefix":null,"givenName":null,"additionalName":null,"familyName":null,"honorificSuffix":null,"nickname":null,"email":null,"photo":null,"category":null,"adr":null,"tel":[{"type":null,"value":"+0988782456","carrier":null}],"org":null,"jobTitle":null,"bday":null,"note":null,"impp":null,"url":null,"anniversary":null}
E/GeckoConsole(  878): [JavaScript Error: "formats is undefined" {file: "resource://gre/modules/PhoneNumber.jsm" line: 80}]
Assignee: nobody → anygregor
Flags: needinfo?(anygregor)
Attached patch patchSplinter Review
Attachment #745941 - Flags: review?(gal)
Attachment #745941 - Flags: review?(bent.mozilla)
Comment on attachment 745941 [details] [diff] [review]
patch

Review of attachment 745941 [details] [diff] [review]:
-----------------------------------------------------------------

Ok.
Attachment #745941 - Flags: review?(bent.mozilla) → review+
Keywords: checkin-needed
(In reply to Carlos Martínez Toral [:carlosmartinez] from comment #41)
> Created attachment 745847 [details]
> SIM import log with extra debug info from arcturus branch

Could you try with my fix?
Flags: needinfo?(carlos.martinez)
https://hg.mozilla.org/projects/birch/rev/0af678fcaeef

Note that the various uplift queries ignore bugs that have NPOTB in the whiteboard, so you may want to remove that if you expect this to end up on b2g18.
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: IOT, Chile, Spain, Ikura, khepera_43608 [NPOTB] → IOT, Chile, Spain, Ikura, khepera_43608
https://hg.mozilla.org/mozilla-central/rev/0af678fcaeef
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Depends on: 869273
Finally I´ve been able to try Gregor´s patch and seems to be working fine, although I don´t have the original SIM anymore, I´ve created a contact with same phone numbers.
Flags: needinfo?(carlos.martinez)
@Carlos, the same phone number in a version without Gergor's patch has this problem?
I got the problematic number from the excel sheet and added a testcase for it.
I can't remember the exact number but it was one from:
+TestProperties("+0988782456");
+TestProperties("+34556657");
+TestProperties("+66554433");
+TestProperties("+43442075");
+TestProperties("+13442074");
Attachment #745941 - Flags: review?(gal) → review+
Verified fixed on 5/13 partner build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.