Closed Bug 860881 Opened 9 years ago Closed 8 years ago

[B2G][Notification][Gallery] Screenshot selected in notification does not open screenshot in Gallery

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ahubenya, Assigned: sharaf.tir)

References

Details

(Keywords: feature, Whiteboard: burirun1.3-2, Burirun1.4-1)

Attachments

(2 files)

Attached file logcat
Description:
When user takes a screen shot and attempts to open it through the notifications, user is discarded from notifications screen. 

Repro Steps:
1) Updated to Unagi Build ID: 20130411070205
2) Press the “home” and “sleep” button together
3) User receives a notification “Screenshot saved to Gallery”
4) Wait a second or two for that notification to disappear
5) Pull down notifications screen
6) Select screenshot that was saved

Actual:
User is discarded from notifications screen.

Expected:
User is directed to the Gallery app and opens screenshot.

Environmental  Variables:
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/f671fa539473
Gaia: e7e338a765e22334b40ced41489a785941382c66

Repro frequency: 100%
See attached logcat.
Duplicate of this bug: 796638
Issue is still reproducing. User is not taken to Gallery when screenshot is selected from Notifications menu. 

Leo Device
Environmental Variables
Build ID: 20130805071207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a2a9b89ef5ee
Gaia: 45f6a739b09292e16717fb21003386c914ca29c2
Platform Version: 18.1
Alive, Can you please assign this issue to me. I have a patch for this :-)
Flags: needinfo?(alive)
No problem
Assignee: nobody → sharaf.tir
Flags: needinfo?(alive)
Attached file Link to pull request
Added support for opening gallery application from screenshot notification.
Attachment #8360188 - Flags: review?(alive)
Comment on attachment 8360188 [details]
Link to pull request

Lemme know if you need help to merge.
Attachment #8360188 - Flags: review?(alive) → review+
Whiteboard: burirun1.3-2
Whiteboard: burirun1.3-2 → burirun1.3-2, Burirun1.4-1
Duplicate of this bug: 980673
Hi Alive,

Can you please merge it?

ni? to alive
Flags: needinfo?(alive)
Unfortunately the pull request is not rebased. Please do and ask for merge again.
Flags: needinfo?(alive) → needinfo?(sharaf.tir)
I rebased the patch and merged in: https://github.com/mozilla-b2g/gaia/commit/e355cfe11b7774aef0a7fd218ee1f065d98e12c9

Was the same code as the original patch, screenshot.js had just switched to the new notification api already so some lines moved, Sharaf is still listed as the author
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(sharaf.tir)
Resolution: --- → FIXED
Keywords: feature
You need to log in before you can comment on or make changes to this bug.