Awful debug spew on linux

RESOLVED FIXED in mozilla23

Status

()

Core
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jdm, Assigned: billm)

Tracking

(Blocks: 1 bug)

unspecified
mozilla23
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
My debug (desktop Firefox, mozilla-central) build console output is filled with this:

>[debug] epoll_dispatch: epoll_wait reports 1
>[debug] event_active: 0x7ff6480220d0 (fd 11), res 2, callback 0x7ff644b2f5fe
>[debug] event_process_active: event: 0x7ff6480220d0, EV_READ  call 0x7ff644b2f5fe
>[debug] event_base_loop: asked to terminate loop.
>Socket connect errno=22
>OnConnectError
>OnDisconnect

It's really distracting. Can we at least turn this off for desktop, where it doesn't seem like this code should be running?
Did a bit of quick digging and it looks like it's coming from bug 842887 (unless I didn't dig far enough):

http://hg.mozilla.org/mozilla-central/rev/71545c41ea4c
http://hg.mozilla.org/mozilla-central/diff/71545c41ea4c/ipc/chromium/src/third_party/libevent/log-internal.h

cc'ing (hopefully) relevant people.
Blocks: 842887

Updated

5 years ago
Component: General → General
Product: Boot2Gecko → Core
This was bug 858204.
Blocks: 858204
No longer blocks: 842887
Hmm. This is actually being seen in non-b2g desktop builds? We shouldn't be trying to open sockets there, so that's kind of worrisome.

Comment 4

5 years ago
I don't understand. Why wouldn't this affect OOPP?

Comment 5

5 years ago
I'm seeing this on Mac too.
Blocks: 341986
I thought these messages are from the FxOS RIL socket trying to reconnect, which shouldn't even be built into desktop firefox?

Comment 7

5 years ago
What is "RIL"?

Chromium uses libevent for its event loop mechanics, which we certainly do use on Linux and Mac for out-of-process plugins.
(Assignee)

Comment 8

5 years ago
This is extremely annoying and it makes it much more difficult to do printf debugging. I'm getting hundreds of lines of spew just from visiting a normal web page. The original bug is pretty vague about why this was added. Can we just take it out? If not, is there a way to enable it only on tryserver? That seems to have been the intended use.
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #7)
> What is "RIL"?
RIL is the "radio interface layer". https://wiki.mozilla.org/B2G/RIL
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #7)
> What is "RIL"?
> 
> Chromium uses libevent for its event loop mechanics, which we certainly do
> use on Linux and Mac for out-of-process plugins.

Oh yeah, that's not the messages I was talking about. It's the 

">Socket connect errno=22
>OnConnectError
>OnDisconnect"

I'm fairly (but not completely) sure those are from the RIL (radio interface layer, how we talk to the cell modem in FxOS) socket trying to connect to its socket for some reason. I'm building desktop without ENABLE-MOZ-RIL now to see what's going on.
Ok, I can't replicate this with my desktop debug build of m-c. Can I see the mozconfig someone that's seeing this is building with?
(Assignee)

Comment 12

5 years ago
It's just a normal desktop FF build. I don't think that the "[debug] ..." messages have anything to do with RIL. They're just from the Chromium IPC code. As Ted said, this is a regression from bug 858204. I'm adding needinfo? for Mike Hommey to find out what this is for and how we could eliminate the spew in the common case.
Flags: needinfo?(mh+mozilla)
(In reply to Bill McCloskey (:billm) from comment #12)
> It's just a normal desktop FF build. I don't think that the "[debug] ..."
> messages have anything to do with RIL. They're just from the Chromium IPC
> code. As Ted said, this is a regression from bug 858204.

I don't see how it's possible for a normal desktop build (a non debug one) to spew these messages.

> I'm adding needinfo? for Mike Hommey to find out what this is for and how we could
> eliminate the spew in the common case.

It was mostly to help debug intermittent weird SIGCHLD crashes on osx we're getting on tbpl. Turned out not to be that helpful. I guess it can be backed out.
Flags: needinfo?(mh+mozilla)
(Assignee)

Comment 14

5 years ago
Created attachment 740614 [details] [diff] [review]
backout patch

Excellent, thanks. The printing only happens in debug builds, but that's what I normally use for debugging. It makes it really hard to see anything on the console.
Assignee: nobody → wmccloskey
Status: NEW → ASSIGNED
Attachment #740614 - Flags: review?(mh+mozilla)
Attachment #740614 - Flags: review?(mh+mozilla) → review+
(Assignee)

Comment 15

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/9a8232d88dc4
https://hg.mozilla.org/mozilla-central/rev/9a8232d88dc4
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
You need to log in before you can comment on or make changes to this bug.