Closed Bug 860922 Opened 7 years ago Closed 7 years ago

[leo][RIL build][sms] sms message causes the device to lockup

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, blocker)

ARM
Gonk (Firefox OS)
defect
Not set
blocker

Tracking

(blocking-b2g:leo+, b2g18 affected)

RESOLVED DUPLICATE of bug 857632
blocking-b2g leo+
Tracking Status
b2g18 --- affected

People

(Reporter: nhirata, Assigned: alhadp)

Details

(Keywords: smoketest, Whiteboard: leorun1)

Attachments

(1 file)

Attached file logcat
## Environment :
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/f671fa539473
Gaia   e7e338a765e22334b40ced41489a785941382c66
BuildID 20130411070205
ril01.01.00.19.060
Version 18.0
Leo
## Repro :
1. launch dialer
2. from a different device send an incoming text message

## Expected :
sms notification appears

## Actual :
screen goes completely white and/or device locks up, battery has to be pulled.

## Note :
blocking-b2g: --- → leo?
Summary: [leo][sms] incoming sms message causes the screen to go white → [leo][RIL build][sms] incoming sms message causes the device to lockup
coming back up, it shows that the device crashed: https://crash-stats.mozilla.com/report/index/fd568c47-f87f-43a8-85b2-8b1572130411

We need to get symbols up to the symbol server.  I'll follow up in a different bug in regards to that.
Turns out I had already filed one : bug 847539
Turns out that it's also outgoing SMS that will cause the problem.  Marking this as a blocker for testing SMS
Severity: normal → blocker
Summary: [leo][RIL build][sms] incoming sms message causes the device to lockup → [leo][RIL build][sms] sms message causes the device to lockup
related/dup of bug 859876?
bug 859876 is on inari; this is on leo.
Triage 4/12 - Leo+
blocking-b2g: leo? → leo+
Assignee: nobody → kchang
Vicamo, is the root cause of this issue same with Bug 854790?
Assignee: kchang → vyang
(In reply to Ken Chang from comment #6)
> Vicamo, is the root cause of this issue same with Bug 854790?

No. Probably an issue in commercial RIL. No such issue in my local build.
Assignee: vyang → nobody
I can see the SMS event in the log. This problem is in display function. 
> ## Actual :
> screen goes completely white and/or device locks up, battery has to be
> pulled.
> 
We need to check why the screen is white.
Wayne, who can we assign the this display problem?
Flags: needinfo?(wchang)
qawanted to check reproducibility and collect additional logs if possible.

Anshul - can you check if you can see any error from your end?

Thanks
Flags: needinfo?(wchang) → needinfo?(anshulj)
Whiteboard: qawanted
Keywords: qawanted
Whiteboard: qawanted
Could you please let us know which AU you guys are using?
Assignee: nobody → alhadp
Flags: needinfo?(anshulj) → needinfo?(alhadp)
Also WFM with tip Gecko/RIL, so this is prolly a Moz build configuration issue
Keywords: smoketest
The recent QA comment I'm assuming this is reproducible on our end, so this is probably a Mozilla build issue at comment 12 cites.
Keywords: qawanted
This issue most likely is a duplicate of bug 857632.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 857632
Whiteboard: leorun1
Flags: needinfo?(alhadp)
You need to log in before you can comment on or make changes to this bug.