[B2G][Contacts] Time stamp of last contact import is not shown under Gmail or Hotmail in Contact Settings

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: ahubenya, Assigned: crdlc)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ affected)

Details

(Whiteboard: leorun1, inarirun2, leorun3, leorun4, retest_leorun4)

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 736562 [details]
Screenshot

Description:
There is no time stamp/period shown of the last time the contacts have been imported from Gmail

Repro Steps: 
1) Updated to Unagi Build ID: 20130411070205
2) Open Contacts app
3) Select Settings icon
4) Select Gmail (listed under “Import Contacts”)
5) Sign in to Gmail account
6) Import contacts
7) Wait awhile

Check for time stamp- 
1) Open Contacts app
2) Select Settings icon
3) Time of last import should be shown under Gmail 

Actual:
No time period of last import is shown. 

Expected:
Information about when the last import was performed is shown.

Environmental  Variables:
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/f671fa539473
Gaia: e7e338a765e22334b40ced41489a785941382c66

Repro frequency: 2/2
Test Suite Name: Testrun 1.1a
UCID: contacts-002
Link to failed test case: https://moztrap.mozilla.org/runtests/run/1088/env/305/?pagenumber=1&pagesize=20&sortfield=order&sortdirection=asc&filter-id=7056

See attached screenshot

Comment 1

5 years ago
We would need a visual design amendment in Contact Settings page in order to show the last update time. Or another visual solution that does not take so much real state in the screen. Requesting info from Sergi.
Assignee: nobody → jmcf
Flags: needinfo?(sergiov)

Comment 2

5 years ago
Is this a requirement i can check in any documentation we may have?
Do we need this use this same solution for the other services like hotmail?
Can you better specify the information and time format to be shown? (dd/mm/yy, weekday dd/mm/yy, updated 2 hours ago...)

Thanks
Flags: needinfo?(sergiov)

Comment 3

5 years ago
the wireframe is in dropbox, production/interaction/apps/contacts. But I think you made a good point, about the format to be shown in the last update field. Perhaps Ayman can say more about that as he designed the wireframe.

Comment 4

5 years ago
I believe we should block on this as the wireframe indicates that the last updated timestamp should be shown and I recall Ayman to mention it as important. 

Requesting info from Ayman anyway.
blocking-b2g: --- → leo?
Flags: needinfo?(aymanmaat)

Comment 5

5 years ago
Ok. Will keep this on hold until we have the info you refer to.

Thanks
blocking-b2g: leo? → -
status-b2g18: --- → affected
tracking-b2g18: --- → +

Updated

5 years ago
Whiteboard: leorun1
(Reporter)

Comment 6

5 years ago
This issue exists on Hotmail as well. See link to failed TC below. 

Leo device
Build ID: 20130411070205
Kernel Date: Mar 15
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/f671fa539473
Gaia: e7e338a765e22334b40ced41489a785941382c66

Notes:
Repro frequency: 2/2, 100%
Test Suite Name: Contacts
UCID: 0wd-23761
Link to failed test case: https://moztrap.mozilla.org/runtests/run/1117/env/314/?pagenumber=1&pagesize=100&sortfield=order&sortdirection=asc&filter-id=7214&filter-suite=215
Q Analysts Test Team Priority:   Pri 3

Comment 7

5 years ago
(In reply to Sergi from comment #2)
> Is this a requirement i can check in any documentation we may have?
> Do we need this use this same solution for the other services like hotmail?
> Can you better specify the information and time format to be shown?
> (dd/mm/yy, weekday dd/mm/yy, updated 2 hours ago...)
> 
> Thanks

Attaching the import contact specifications. Regarding date presentation. I would be pragmatic about it and follow the same convention that is implemented in the call log and in the messaging app.
Flags: needinfo?(aymanmaat)

Comment 8

5 years ago
Created attachment 752098 [details]
HTML5_Import Gmail and Hotmail Contacts_20130304_V1.0

attached as per comment 7

Updated

5 years ago
Duplicate of this bug: 875149

Updated

5 years ago
Summary: [B2G][Contacts] Time stamp of last contact import is not shown under Gmail in Contact Settings → [B2G][Contacts] Time stamp of last contact import is not shown under Gmail or Hotmail in Contact Settings

Comment 10

5 years ago
we need the visual design to add that information to the Contact Settings screen.
Flags: needinfo?(sergiov)

Updated

5 years ago
Whiteboard: leorun1 → leorun1, inarirun2

Updated

5 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 11

5 years ago
Flagging Przemek as this requires VxD, not IxD. Przemek, please feel free to reassign as necessary.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(pabratowski)

Comment 12

5 years ago
Created attachment 760310 [details]
Contacts Settings :: Time Stamp :: Visuals

Find attached a screenshot of the contacts settings screen with the time stamp next to each import source.
Flags: needinfo?(sergiov)
Sergi has provided the visual design.
Flags: needinfo?(pabratowski)

Comment 14

5 years ago
I have a concern with the proposed design. You have missed the fact that we also have the 'Import from SDCard' option so I believe we are going to occupy too much real state. Maybe we could have the last import date someplace besides the button or something like that.

Comment 15

5 years ago
(In reply to Jose M. Cantera from comment #14)
> I have a concern with the proposed design. You have missed the fact that we
> also have the 'Import from SDCard' option so I believe we are going to
> occupy too much real state. Maybe we could have the last import date
> someplace besides the button or something like that.

My recommendation is to use the standard list buttons here and any information related to them below. Eventually we may have even more sources to import contacts from, so we should pile them as a list at some point. If they don't fit one single screen the user will have to scroll down. I think that's a common behavior, and there won't be any problem in the user to scroll down to discover all the content in the screen.

Comment 16

5 years ago
Created attachment 761348 [details]
Contacts Settings :: Time Stamp :: Visuals

After talking with Ayman and reviewing your comments regarding where to place the time stamp in contact settings, we've made a slight redesign to improve flexibility and scalability.

If we have the two lines of text underneath each other  we can allow the text length to increase. This means we can comfortably handle data source names that are longer than 'hotmail' and also alternative date formats like: 24th September 2012.

This also involves implementing a custom version of the list button BB for this case, basically making it taller to fit 2 lines of text.

Hope you like the new design :)
Attachment #760310 - Attachment is obsolete: true
(Assignee)

Updated

5 years ago
Assignee: jmcf → crdlc
(Assignee)

Comment 17

5 years ago
Created attachment 762561 [details]
Patch v1
Attachment #762561 - Flags: review?(jmcf)

Comment 18

5 years ago
Comment on attachment 762561 [details]
Patch v1

works perfectly. good work

thanks!
Attachment #762561 - Flags: review?(jmcf) → review+
(Assignee)

Comment 19

5 years ago
https://github.com/mozilla-b2g/gaia/commit/6e09b71caf5c63d5c81574dec3cf3b6f54e2fdee
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 20

5 years ago
Comment on attachment 762561 [details]
Patch v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature
User impact if declined: this patch prints the last import date for live, sd, sim and gmail contacts. This info is really useful so users knows when they imported the last time
Testing completed: manually and unit testing
Risk to taking this patch (and alternatives if risky): low, added new code but we didn't touch almost other components
String or UUID changes made by this patch:
Attachment #762561 - Flags: approval-gaia-v1?

Updated

5 years ago
Whiteboard: leorun1, inarirun2 → leorun1, inarirun2, leorun3
Comment on attachment 762561 [details]
Patch v1

Approvals are now closed. Please nominate for blocking-b2g:leo? for critical issues.
Attachment #762561 - Flags: approval-gaia-v1?

Updated

5 years ago
blocking-b2g: - → leo?
Triage agrees we can take this in the next release.
blocking-b2g: leo? → -
(Reporter)

Updated

5 years ago
Whiteboard: leorun1, inarirun2, leorun3 → leorun1, inarirun2, leorun3, leorun4
Still repros on Leo 1.1 commercial RIL.

Build ID: 20130715070218
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/6062fdf2deb8
Gaia: 55ed5e08a2250ea2d3571fff860c39e66fabed14
Platform Version: 18.1
RIL Version: 01.01.00.019.158
Whiteboard: leorun1, inarirun2, leorun3, leorun4 → leorun1, inarirun2, leorun3, leorun4, retest_leorun4

Comment 24

5 years ago
this bug is not uplifted in v1.1 thus in Leo will be there to stay

Comment 25

5 years ago
The timestamp is not shown yet. As Jose M. commented above the uplift seems not to be done. 

John, 
As this bug is in the list Resol-fixed bugs to be tested, should I change the status tu Re-open to follow this? Or anyother way mark it has already been checked?
Thanks
Flags: needinfo?(jhammink)

Comment 26

5 years ago
Good question.  For now I'll remove this from our query of "resolved" fixes by moving to verified, and flagging as invalid.   We should flag the referring moztrap testcase as invalid as well.
Status: RESOLVED → VERIFIED
Flags: needinfo?(jhammink) → in-moztrap-
Resolution: FIXED → INVALID
(Reporter)

Comment 27

5 years ago
Created attachment 782858 [details]
screenshot master-central

The fix was implemented in the mozilla central build and I am able to verify the fix landed properly. 
Test cases 7056 & 7214 are still valid for 1.2

Build ID: 20130726030202
Gecko: http://hg.mozilla.org/mozilla-central/rev/46d73e889cb4
Gaia: a3d7268219f6ff92d296a3305bdfef14209885dc
Platform Version: 25.0a1
(Reporter)

Updated

5 years ago
Resolution: INVALID → FIXED
You need to log in before you can comment on or make changes to this bug.