The application receipt: https://wiki.mozilla.org/Apps/WebApplicationReceipt Defines that typ: MUST be the string "purchase-receipt". In the past I've put different kinds of receipt in the product dict. I think that's a mistake and we should allow the typ to be changed. Some of the typ values could be: * purchase-receipt: a valid sale * developer-receipt: a developers receipt * reviewer-receipt: a reviewer receipt * test-receipt: a test receipt For sales a developer should still check "purchase-receipt" so really nothing changed. A developer should optionally support "developer-receipt" and "reviewer-receipt". A developer should only support "test-receipt" during testing under circumstances for their own testing, but never for a live app.
sounds good to me
https://github.com/mozilla/zamboni/commit/b720da And Wiki updated.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.