apprtc.appspot.com causes RTCPeerConnection alert

RESOLVED WORKSFORME

Status

()

Core
WebRTC
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: richard.screene, Unassigned)

Tracking

21 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WebRTC][blocking-webrtc-])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:21.0) Gecko/20100101 Firefox/21.0
Build ID: 20130408165307

Steps to reproduce:

Navigate to the reference application apprtc.appspot.com using two machines (one MacBook and one MacBook Pro) and go to the same room.



Actual results:

On Firefox beta and Nightly I get the following alert pop-up:
"Cannot create RTCPeerConnection object; WebRTC is not supported by this browser."

On the stable release I just the local camera displayed for both local and remote streams for each end.


Expected results:

I'm sure before I had the local and remote streams displayed properly.

Updated

5 years ago
Component: Untriaged → WebRTC
Product: Firefox → Core
QA Contact: jsmith
What version of Nightly? Can you double check you are the latest nightly here when testing?

Works for me on 4/12.
Flags: needinfo?(richard.screene)

Updated

5 years ago
Whiteboard: [WebRTC][blocking-webrtc-]
(Reporter)

Comment 2

5 years ago
My apologies, I didn't realise Nightly didn't update automagically!
I've now updated to 4/12 and I'm getting a different problem.

On machine A I'm seeing the local camera in both the main and inset windows.
On machine B I'm seeing the remote camera in the main screen and there is no local window.

I'll investigate more on Monday.
Flags: needinfo?(richard.screene)
Okay. That sounds like a new bug. Since the original bug then now is confirmed to be a wfm, I'm closing this.

When you confirm the issue you are seeing, feel free to open a new bug in Core --> WebRTC. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.