Intermittent failure to stop WebRTC conduits (repeated SendRTCPPacket Failed errors until shutdown)

RESOLVED DUPLICATE of bug 849010

Status

()

Core
WebRTC
RESOLVED DUPLICATE of bug 849010
5 years ago
5 years ago

People

(Reporter: RyanVM, Assigned: abr)

Tracking

({assertion, crash, intermittent-failure})

Trunk
x86_64
Windows 7
assertion, crash, intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WebRTC],[blocking-webrtc-][webrtc-uplift])

(Reporter)

Description

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=21727489&tree=Mozilla-Inbound

Rev3 WINNT 6.1 mozilla-inbound debug test mochitest-3 on 2013-04-11 19:16:00 PDT for push c81138a2c6ad
slave: talos-r3-w7-073

03:06:52     INFO -  Assertion failure: ((bool)(!!(!NS_FAILED_impl(rv)))), at e:\builds\moz2_slave\m-in-w32-d-0000000000000000000\build\media\mtransport\runnable_utils.h:48
03:06:52     INFO -  --DOCSHELL 0FFC6B40 == 5 [id = 3259]
03:06:52     INFO -  --DOMWINDOW == 62 (10376F48) [serial = 10627] [outer = 103765A8] [url = http://example.com/tests/dom/tests/mochitest/localstorage/frameQuotaSessionOnly.html?add&A&success]
03:06:52     INFO -  --DOMWINDOW == 61 (053B5B68) [serial = 10599] [outer = 00000000] [url = http://example.org/tests/dom/tests/mochitest/localstorage/frameMasterNotEqual.html]
03:06:52     INFO -  --DOMWINDOW == 60 (053B40F0) [serial = 10598] [outer = 00000000] [url = about:blank]
03:06:52     INFO -  --DOMWINDOW == 59 (053B3750) [serial = 10597] [outer = 00000000] [url = about:blank]
03:06:52     INFO -  --DOMWINDOW == 58 (053B51C8) [serial = 10594] [outer = 00000000] [url = http://mochi.test:8888/tests/dom/tests/mochitest/localstorage/test_localStorageOriginsPortDiffs.html]
03:06:52     INFO -  --DOMWINDOW == 57 (053B3E88) [serial = 10593] [outer = 00000000] [url = http://mochi.test:8888/tests/SimpleTest/iframe-between-tests.html]
03:06:52     INFO -  --DOMWINDOW == 56 (053B69D8) [serial = 10607] [outer = 00000000] [url = http://example.com/tests/dom/tests/mochitest/localstorage/frameMasterNotEqual.html]
03:06:52     INFO -  --DOMWINDOW == 55 (053B39B8) [serial = 10606] [outer = 00000000] [url = about:blank]
03:06:52     INFO -  --DOMWINDOW == 54 (053B4A90) [serial = 10605] [outer = 00000000] [url = about:blank]
03:06:52     INFO -  --DOMWINDOW == 53 (053B62A0) [serial = 10602] [outer = 00000000] [url = http://mochi.test:8888/tests/dom/tests/mochitest/localstorage/test_localStorageOriginsSchemaDiffs.html]
03:06:52     INFO -  --DOMWINDOW == 52 (053B6770) [serial = 10601] [outer = 00000000] [url = http://mochi.test:8888/tests/SimpleTest/iframe-between-tests.html]
03:06:52     INFO -  --DOMWINDOW == 51 (053B6508) [serial = 10600] [outer = 00000000] [url = http://example.org:8000/tests/dom/tests/mochitest/localstorage/frameSlaveNotEqual.html]
03:06:52     INFO -  --DOCSHELL 133BEA70 == 4 [id = 3256]
03:06:52     INFO -  --DOCSHELL 05487540 == 3 [id = 2]
03:06:52     INFO -  --DOCSHELL 0FFC63A8 == 2 [id = 3258]
03:06:52     INFO -  --DOCSHELL 17E7BD00 == 1 [id = 3257]
03:06:52     INFO -  --DOCSHELL 0C4717F8 == 0 [id = 5]
03:06:52     INFO -  --DOMWINDOW == 50 (1F944928) [serial = 10657] [outer = 1F943D20] [url = about:blank]
03:06:52  WARNING -  TEST-UNEXPECTED-FAIL | Shutdown | Exited with code -2147483645 during test run
03:06:53     INFO -  INFO | automation.py | Application ran for: 0:46:00.754000
03:06:53     INFO -  INFO | zombiecheck | Reading PID log: c:\users\cltbld\appdata\local\temp\tmpa6unvopidlog
03:06:53     INFO -  ==> process 2756 launched child process 1904
03:06:53     INFO -  ==> process 2756 launched child process 2460
03:06:53     INFO -  ==> process 2756 launched child process 4028
03:06:53     INFO -  ==> process 2756 launched child process 4000
03:06:53     INFO -  ==> process 2756 launched child process 260
03:06:53     INFO -  ==> process 2756 launched child process 2024
03:06:53     INFO -  ==> process 2756 launched child process 3452
03:06:53     INFO -  ==> process 2756 launched child process 2588
03:06:53     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 1904
03:06:53     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2460
03:06:53     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 4028
03:06:53     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 4000
03:06:53     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 260
03:06:53     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2024
03:06:53     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 3452
03:06:53     INFO -  INFO | zombiecheck | Checking for orphan process with PID: 2588
03:07:12  WARNING -  PROCESS-CRASH | Shutdown | application crashed [@ mozilla::RUN_ON_THREAD]
03:07:12     INFO -  Crash dump filename: c:\users\cltbld\appdata\local\temp\tmplgrwys\minidumps\dfd6ed1c-9e5f-48aa-b440-310c344558ce.dmp
03:07:12     INFO -  Operating system: Windows NT
03:07:12     INFO -                    6.1.7600
03:07:12     INFO -  CPU: x86
03:07:12     INFO -       GenuineIntel family 6 model 23 stepping 10
03:07:12     INFO -       2 CPUs
03:07:12     INFO -  Crash reason:  EXCEPTION_BREAKPOINT
03:07:12     INFO -  Crash address: 0x6c114ee6
03:07:12     INFO -  Thread 39 (crashed)
03:07:12     INFO -   0  xul.dll!mozilla::RUN_ON_THREAD [runnable_utils.h:c81138a2c6ad : 48 + 0x41]
03:07:12     INFO -      eip = 0x6c114ee6   esp = 0x11aaef7c   ebp = 0x11aaef90   ebx = 0x6caadf28
03:07:12     INFO -      esi = 0x10656b20   edi = 0x00582ef4   eax = 0x00000000   ecx = 0x5f03514e
03:07:12     INFO -      edx = 0x729ee4d8   efl = 0x00000202
03:07:12     INFO -      Found by: given as instruction pointer in context
03:07:12     INFO -   1  xul.dll!mozilla::RUN_ON_THREAD [runnable_utils.h:c81138a2c6ad : 63 + 0xa]
03:07:12     INFO -      eip = 0x6c11501d   esp = 0x11aaef98   ebp = 0x11aaefa0
03:07:12     INFO -      Found by: call frame info
03:07:12     INFO -   2  xul.dll!mozilla::MediaPipeline::PipelineTransport::SendRtcpPacket(void const *,int) [MediaPipeline.cpp:c81138a2c6ad : 594 + 0x2c]
03:07:12     INFO -      eip = 0x6c115c2e   esp = 0x11aaefa8   ebp = 0x11aaefbc
03:07:12     INFO -      Found by: call frame info
03:07:12     INFO -   3  xul.dll!mozilla::WebrtcAudioConduit::SendRTCPPacket(int,void const *,int) [AudioConduit.cpp:c81138a2c6ad : 672 + 0x11]
03:07:12     INFO -      eip = 0x6c0c499e   esp = 0x11aaefc4   ebp = 0x11aaefd8
03:07:12     INFO -      Found by: call frame info
03:07:12     INFO -   4  xul.dll!webrtc::voe::Channel::SendRTCPPacket(int,void const *,int) [channel.cc:c81138a2c6ad : 342 + 0xb]
03:07:12     INFO -      eip = 0x6c2ced45   esp = 0x11aaefe0   ebp = 0x11aaf000
03:07:12     INFO -      Found by: call frame info
03:07:12     INFO -   5  xul.dll!webrtc::RTCPSender::SendToNetwork(unsigned char const *,unsigned short) [rtcp_sender.cc:c81138a2c6ad : 1926 + 0x12]
03:07:12     INFO -      eip = 0x6c28eef7   esp = 0x11aaf008   ebp = 0x11aaf01c
03:07:12     INFO -      Found by: call frame info
03:07:12     INFO -   6  xul.dll!webrtc::RTCPSender::SendRTCP(unsigned int,int,unsigned short const *,bool,unsigned __int64) [rtcp_sender.cc:c81138a2c6ad : 1916 + 0x13]
03:07:12     INFO -      eip = 0x6c2918da   esp = 0x11aaf024   ebp = 0x11aaf670
03:07:12     INFO -      Found by: call frame info
03:07:12     INFO -   7  xul.dll!webrtc::ModuleRtpRtcpImpl::Process() [rtp_rtcp_impl.cc:c81138a2c6ad : 261 + 0x11]
03:07:12     INFO -      eip = 0x6c2844ba   esp = 0x11aaf678   ebp = 0x11aaf780
03:07:12     INFO -      Found by: call frame info
This is the result of some failure-to-shutdown bug much earlier (see the full logs).

STS can fail IsOnCurrentThread (nothing really can) if STS has been shut down (mPool == nullptr), which happens in xpcom-shutdown-threads.  If we don't shutdown, we'll keep trying to do things with STS even after it's gone.  Bug 856848 revises this code in runnable_utils to not MOZ_ASSERT but instead NS_ENSURE_TRUE.    If it shows up again, it will be an assertion or warning from NS_ENSURE_TRUE (and repeated errors/warning debugs in the logs about failure to send RTCP and from nsGlobalWindow (I think))

It *may* have started around 02:36:21

abr/jib: if you think this is better dupped to bug 849010 or a different one, let me know.
Assignee: nobody → adam
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Depends on: 856848
Resolution: --- → DUPLICATE
Summary: Intermittent mochitest-3 Shutdown | Exited with code -2147483645 during test run | application crashed [@ mozilla::RUN_ON_THREAD] from "Assertion failure: ((bool)(!!(!NS_FAILED_impl(rv))))" → Intermittent failure to stop WebRTC conduits (repeated SendRTCPPacket Failed errors until shutdown)
Whiteboard: [WebRTC],[blocking-webrtc-][webrtc-uplift]
Duplicate of bug: 849010
You need to log in before you can comment on or make changes to this bug.